locked
Newbie Question - ASP.Net version in IIS RRS feed

  • Question

  • User1614190077 posted

    When I create a new website in IIS and its associated application pool, I get the option of setting the .NET framework to 1.0 or 2.0.

    Via windows updates I have installed versions 3.0 and 3.5..however these dont show up in the drop down list.

    I read that the aspnet_regiis -i command needs to be run in the installed .NET framework folder for it to be visible in IIS.

    However, the aspnet_regiis.exe is only present in the 1.0 and 2.0 folders. Can I use the same exe to register the 3.5 framework with IIS?

    Let me know.

    Thanks,

    Jake. 

    Thursday, January 7, 2010 7:33 PM

Answers

  • User-158764254 posted

    IIS will only show you the versions of the CLR that are available  (1.1 or 2.0)

    asp.net 3.0 and 3.5 both actually use the 2.0 CLR... they simply add some additional assemblies to it.

    so if you are setting up a 3.0 or 3.5 app, you would select the 2.0 setting in IIS

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 7, 2010 9:27 PM

All replies

  • User-158764254 posted

    IIS will only show you the versions of the CLR that are available  (1.1 or 2.0)

    asp.net 3.0 and 3.5 both actually use the 2.0 CLR... they simply add some additional assemblies to it.

    so if you are setting up a 3.0 or 3.5 app, you would select the 2.0 setting in IIS

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 7, 2010 9:27 PM
  • User1391799836 posted

    Hey Mike what is the version of IIS Server.?  What tool are you using in creating the application?   So I can tell you where to look to see what version of the Net Framework the application is currently using.

    Monday, January 11, 2010 6:17 AM