locked
Unresponsive touch screen Nokia 1520 wp8.1 RRS feed

  • Question

  • Hello. I am experiencing intermittent unresponsiveness from the touch screen after 8.1 dev preview update.. When it is working, it will skip all over the screen, opening apps and Cortana without hard presses. Any thoughts?
    Thursday, April 17, 2014 10:10 PM

All replies

  • This seems to be limited to your phone, I have a 1520 here that is working fine with the preview on it.

    If the screen isn't responding, give a soft reset a shot.  Hold Power and Volume Down for 10-15 seconds, the phone should restart.  If that doesn't work, you may need to do a hard reset.  It is possible to do this using the buttons, if the touch screen isn't working.

    1.Turn the power off
    2.Press and hold the Volume Down button, and then briefly
    press the Power button, until the phone vibrates.
    3.Release the Volume Down button when you see an icon on the
    screen.
    4.Then press the following buttons in this sequence:  Volume Up > Volume Down > Power > Volume Down

    Give that a shot.

    Regards,

    Kevin J S

    Saturday, April 19, 2014 4:02 AM
    Moderator
  • I have the same problem, I tried the soft reset and it didn't work, I even try with a hard reset and it work for a week but now the problem is back (also with a Lumia 1520)
    Friday, April 25, 2014 10:34 PM
  • I am also having this issue and I have tried both soft and hard reset many times and still comes right back.
    Thursday, May 29, 2014 4:35 PM
  • I'm having the same issue with my 1520.  Everything was fine when I first installed the 8.1 preview but in the last two weeks my screen is freezing up, and random phantom taps are happening, opening up various tiles, Cortana, etc.  I've tried a variety of different fixes on this forum except a factory reset (nervous to do that considering other posts where phones are bricked after trying to do this on a preview OS).  Anyone had any progress in resolving this?
    Wednesday, June 11, 2014 7:00 PM
  • I have began facing the same issues for L920. I only recently factory reset it and was working fine until a few days ago. I was worried that perhaps, it was just me. Has anyone been able to resolve this issue?

    Monday, July 14, 2014 3:20 AM