locked
JPG Images showing fine, but not PNG's RRS feed

  • Question

  • I have a png version and a jpg version of the same image and when I switch between the two I get the jpg to show fine while the png does not show up at all (both shows up fine on a std. ASP.NET - HTML page). The tags are as follows,

    <Image x:Name="Image_1" Canvas.Left="2083" Canvas.Top="1994" Source="../images/library/crying.jpg" />


    <Image x:Name="Image_1" Canvas.Left="2083" Canvas.Top="1994" Source="../images/library/crying.png" />

    Is there any reasons why the jpg should "work" (i.e. becomes visible) and not the png (as I understand WPF/E supports these two formats); the two tags are equal except for the extensions.

     

    Any help is greatly appreciated, Thanks.

     

    Kind Regards

    Hans P. Dramstad

    Tuesday, April 10, 2007 8:49 PM

Answers

  • Since the Feb CTP we've fixed a bunch of PNG bugs and my hope is this problem too is fixed in the next release. If possible, please share the image and we'll test to make sure it indeed works in our internal builds.
    Saturday, April 14, 2007 3:20 PM

All replies

  • Since the Feb CTP we've fixed a bunch of PNG bugs and my hope is this problem too is fixed in the next release. If possible, please share the image and we'll test to make sure it indeed works in our internal builds.
    Saturday, April 14, 2007 3:20 PM
  • Having the same problem with vs2010 ultimate.

    the .png image was showing until a certain point when i rebuilt the app and it ceased showing - i can't remember what were the changes but they were not connected to the image itself or the way I display it. in short I end up with a line of <Image... and when I set a .bmp or .ico image - it shows but when I set the same image in .png version it will not show.
    So I created another project and the .png image is showing in there, it seems that somehow the resources are getting fizzlled with png's.

    Regards,
    Gil Y.

     

    Tuesday, November 16, 2010 2:26 AM