locked
Can't install visual studio 2010

    Question

  • Hi,

    i installed windows 8 developer preview. Also i installed visual studio 2011 developer preview (Metro apps). Now i need to install visual studio 2010 for phone development.When i try to install vs2010, its getting failed. here i enclosed the failure image. Please suggest me to resolve this pblm.

     

     


    Regards Sheik Abdullah L
    Monday, January 30, 2012 7:13 AM

Answers

  • Click on View Error log and look which error message yo get. I think it fails because Windows 8 includes .net 4.5 and VS2010 tries to install .net 4.0
    "A programmer is just a tool which converts caffeine into code"

    • Marked as answer by SheikAbdullah Friday, February 03, 2012 5:48 AM
    Tuesday, January 31, 2012 8:37 PM

All replies

  • The compatible version of Visual Studio for Windows 8 Developer Preview is version 2011 that you been installed. Try uninstall that version and uninstall Visual Studio 2010 and reinstall Visual Studio 2010.

    It could be due to compatibility issue, you could try resolve compatibility :

    http://social.technet.microsoft.com/wiki/contents/articles/troubleshoot-compatibility-issues-in-windows-8-developer-preview.aspx

    This version of Windows 8 is pre-Beta and it is just to get idea about direction of Windows 8 Development and to get idea about metro style.

    Monday, January 30, 2012 10:46 AM
  • Hi Sheik Abdullah L,

    If you are in dual boot, try it on the other OS or get advised on using it virtually. Installing two close versions of the same program on the same OS is likely to have issues.


    Irfan
    Monday, January 30, 2012 11:57 AM
  • I tried compatibility issues check.  i doesn't have any issues over there. Is there any other way...
    Regards Sheik Abdullah L
    Monday, January 30, 2012 1:01 PM
  • I have only windows 8. i'll try to install windows 7 either dual boot or virtuallly and then i try to vs2010.. Thanks for ur suggestion...

    Regards Sheik Abdullah L
    Monday, January 30, 2012 1:03 PM
  • Click on View Error log and look which error message yo get. I think it fails because Windows 8 includes .net 4.5 and VS2010 tries to install .net 4.0
    "A programmer is just a tool which converts caffeine into code"

    • Marked as answer by SheikAbdullah Friday, February 03, 2012 5:48 AM
    Tuesday, January 31, 2012 8:37 PM
  • I have all three versions installed sucessfully.  Normally with an application such as a developer environment, you will want to install the earlier versions first, followed by all subsequent versions.

    Tuesday, February 07, 2012 4:02 AM