locked
WSS 3.0 no show results RRS feed

  • Question

  • Hi,

    I have SharePoint Farm running in WS2k3 and WSS Services 3.0, and any search don't show results. The Search Service is Started, and I already restarted it, but none results was found.

    There is any step to make before of to use the Search function?


    Att, Thieslei.
    Tuesday, September 8, 2009 12:44 PM

Answers

All replies

  • Hi, go to Event viewer and saw what errors came.
    View sharepoint logs to see if have any error?
    c:\Program Files\Common Files\Microsoft Shared\web server extensions\12\Logs

    Do you have any problem acessing sharepoint on server where sharepoint is install?

    André Lage Microsoft SharePoint and CRM Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
    Tuesday, September 8, 2009 1:31 PM
  • Hi André,

    Have any errors in the event view applications items:

    =============================================================================

    Event Type: Error
    Event Source: Windows SharePoint Services 3 Search
    Event Category: Gatherer
    Event ID: 2424
    Date:  9/8/2009
    Time:  11:00:24 AM
    User:  N/A
    Computer: BRSAOWS02
    Description:

    The update cannot be started because the content sources cannot be accessed. Fix the errors and try the update again.

    Context: Application 'Search', Catalog 'index file on the search server Search'

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    =============================================================================

    Do you have any informations about this? I will search the error in Internet.


    Att, Thieslei.

    Tuesday, September 8, 2009 2:14 PM
  • Problably is the loopback check problem pelase make the method 2 and restart machine, then try crawl search again.
    http://support.microsoft.com/kb/896861

    Method 2: Disable the loopback check

    Follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. Right-click Lsa, point to New, and then click DWORD Value.
    4. Type DisableLoopbackCheck, and then press ENTER.
    5. Right-click DisableLoopbackCheck, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor, and then restart your computer.

    André Lage Microsoft SharePoint and CRM Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
    Tuesday, September 8, 2009 2:19 PM
  • I already tried this, but I removed the registry entry and add again, restarted the server, but the error still appear in the event viewer.

    In some sites have the information to change the user in the content source, but the user that be in use, have access. I get to connect in the Database by SQL Server Management Studio Express.

    I not understand this.
    Tuesday, September 8, 2009 3:10 PM
  • One question, what account you have on your IIS "application poll>Properties>Indetity", if you have network services change to user or have higher priviliges on sharepoint site, like example:domain\administrator.
    Verify when you create the search Database is the correcto user. 

    How to change service accounts and service account passwords in SharePoint Server 2007 and in Windows SharePoint Services 3.0
    http://support.microsoft.com/kb/934838
    André Lage Microsoft SharePoint and CRM Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
    • Marked as answer by Thyl Oliveira Wednesday, September 9, 2009 8:47 PM
    Tuesday, September 8, 2009 3:16 PM
  • Hi André.

    Thanks for your help. Its working right now.

    Following the steps.

    - I created a new user in my domain;

    - Add to web application as administrator;

    - Stop search server;

    - Deleted the previews "search database" from "Database by SQL Server Management Studio Express";

    - Set permissions to Content Database in SQL as sysadmin.

    - Restart host;

    - Start search service with set the new user;

    - Restart host again;

    ##FINISHED##


    Thanks to all. If someboby need help, send e-mail to me.
    Excuse me for my English.


    Thieslei Oliveira
    thieslei.oliveira@dhl.com

    Wednesday, September 9, 2009 8:56 PM