locked
Xamarin Profiler, unable to take snapshot RRS feed

  • Question

  • User369520 posted

    When I start a new session with just the allocation instrument. When it loads it just gets stuck on reading data in the status bar (see screenshot). When I press the snapshot button nothing happens, well the button greys out but it doesn't appear to anything. I can see some errors in the log(attached) but don't know what the cause is.

    I have tried on a device and on the simulator. (IOS)

    Thanks


    Friday, November 23, 2018 8:02 PM

All replies

  • User99378 posted

    Bushbert did you found a solution for this already? I have the same behaviour. Profiler does not work for me. I don't know if it is related, the available instruments only contains: "Allocations" and "Time profiler". https://docs.microsoft.com/en-us/xamarin/tools/profiler/?tabs=windows shows more instruments.

    Friday, January 18, 2019 8:11 AM
  • User35020 posted

    Indeed, with latest changes in Mono runtime (which xamarin.ios includes), this was broken, and unfortunately there is no workaround. But good news! we have a fix, and are testing it internally, so should be published soon

    Wednesday, March 27, 2019 12:37 PM
  • User381497 posted

    Hi Rodrigo, Did the above issue resolved and the latest version already available? I am using Xamarin Profiler (1.6.4-33) from VS for Mac (8.0.1) and getting this behavior.

    Wednesday, April 10, 2019 12:54 AM
  • User67478 posted

    @jj_pt:

    If I'm reading the changelog correctly, it has been fixed in Xamarin Profiler 1.6.10-15 on 2nd May 2019:

    Fix taking snapshots on iOS profiling.

    Tuesday, August 27, 2019 1:49 PM
  • User381497 posted

    Thanks for the update @anve

    Wednesday, August 28, 2019 2:58 AM