none
AllowSharedUserAppData CSP in Application Management doesn't seem to work RRS feed

  • Question

  • The requirement I am facing is installing an UWP application in the device space. One instance of the application must be maintained accross different users. To address this requirement I took the approach of shared folders. By default the shared folder is not enabled in the pc. We wanted to enable the shared folder for apps guided by microst docs (Am not allowed to add links, just go to mdm microsoft->CSP -> Policy CSP -> Application Management-> AllowSharedUserAppData)using Mobile Device Management. 

    After chaning the value of ApplicationManagement/AllowSharedUserAppData to 1 using replace as give below,

    <Replace>
        <Item>
            <Target>
                <LocURI>./Vendor/MSFT/Policy/Config/ApplicationManagement/AllowSharedUserAppData</LocURI>
            </Target>
            <Meta>
                <Format>int</Format>
            </Meta>
            <Data>1</Data>
        </Item>
        <CmdID>1558041831236</CmdID>
    </Replace>

    Then i used Get to retrieve the data and it was set as 1 also the value is set in the registry.

    Then i created a UWP application to access the shared folder using "ApplicationData.Current.SharedLocalFolder". But it still doesn't work.

    I am aware of the group policy that works fine but i need a solution with MDM CSPs. 


    Friday, May 17, 2019 2:44 PM