locked
Smart Device Extension RRS feed

  • Question

  • Sir,

    I am using VS.NET 2003. I created a Smart device application and tried to run it. This application was just a “Hello world” application. This application didn’t work. The deployment device that I chose was Pocket PC 2002 Emulator. On the Build menu I clicked the Deploy solution so as to deploy the application onto the Pocket PC 2002 Emulator. Pocket PC 2002 Emulator got activated. Soon on the emulator I saw certain progress information like installing .NET Compact framework, copying files etc. Finally deployment got terminated and what I found in the output window of the IDE is shown below.

     

    ------ Build started: Project: SmartDeviceApplication1, Configuration: Release Pocket PC ------

     

    Preparing resources...

    Updating references...

    Performing main compilation...

     

    The project is up-to-date.

    Building satellite assemblies...

    Visual Studio is ready to deploy SmartDeviceApplication1

     

     

     

    ------ Deploy started: Project: SmartDeviceApplication1, Configuration: Release Pocket PC ------

     

    Connected to Pocket PC 2002 Emulator (Pocket PC) running on X86.

    Copying files from 'G:\SmartDeviceApplication1\bin\Release' to '\Program Files\SmartDeviceApplication1'

    Copying SmartDeviceApplication1.exe

     

     

     

    ---------------------- Done ----------------------

     

        Build: 1 succeeded, 0 failed, 0 skipped

        Deploy: 1 succeeded, 0 failed, 0 skipped

     

     

    Launching Application

    Error while trying to run project: Unable to start debugging.

     

    Unable to start program 'G:\SmartDeviceApplication1\bin\Release\SmartDeviceApplication1.exe'.

     

    Let me mention some of the details regarding my PC which might help you to suggest what I can do.

    • I am using 64-bit AMD Athlon Processor.
    • OS: Windows 2000 Advanced Server
    • VS.NET 2003

     

    Every time that I tried to run the application I found that Launching of the application onto the emulator failed. I was not even able to run the samples that come with VS.NET 2003.

     

    Sunday, February 5, 2006 7:21 PM

Answers

  • I spoke to folks internally and here's the reply I got

    For this particular error message, in my experience, the root cause has not been consistent. When I see the following error:

     

    Error while trying to run project: Unable to start debugging.

     

    Unable to start program ‘<path>’.

     

    The problem has been due to:

    -          Some antivirus/firewall blocking communication to the emulator. I’ve found that sometimes you have to uninstall Norton to get deployment to work (even though the customer says they’ve correctly configured their firewall to not block VS2003).

    -          Corrupt security key containers on the desktop. Resolution is to run DelDesktopCryptKey.exe

    Friday, March 10, 2006 5:31 AM

All replies

  • Check your system have administrator rights.
    Monday, February 13, 2006 4:53 AM
  • hello,

    I'm working on XP and this problem appeared few days ago whereas it perfectly worked before. If you have any solutions...

    Thanks.

    Bye

    Sunday, February 26, 2006 2:12 PM
  • I spoke to folks internally and here's the reply I got

    For this particular error message, in my experience, the root cause has not been consistent. When I see the following error:

     

    Error while trying to run project: Unable to start debugging.

     

    Unable to start program ‘<path>’.

     

    The problem has been due to:

    -          Some antivirus/firewall blocking communication to the emulator. I’ve found that sometimes you have to uninstall Norton to get deployment to work (even though the customer says they’ve correctly configured their firewall to not block VS2003).

    -          Corrupt security key containers on the desktop. Resolution is to run DelDesktopCryptKey.exe

    Friday, March 10, 2006 5:31 AM