locked
No search results after wss 3.0 server rebuild RRS feed

  • Question


  • I recreated the config and admin dbs on new sql cluster. The content db for this farm was already on the same cluster. After site collection created and attached to content db I turned on search service which created new search db and then I set site content db to use it. I let it crawl about 5 hours and did a search but could not get any hits. I uploaded a few new files and changed and updated a couple old docs but still could not get any hits. I then stopped the service and started it again, which created a new search db. I then repeated the process but I am still not getting any hits. There are no crawl errors in the wss log or the app event log. 

    Any ideas?

    Thanks,
    Greg Shell
    Sunday, September 27, 2009 2:02 AM

Answers

  • Hi,

     

    Because you recreate the farm and attach the content database, one possible reason is that the Search Server is not associated with the content database.

    Please make sure the Search Server is specified through: Central Administration > Application Management > Content Databases > Manage Content Database Settings

     

    After that, try to manually start a full crawl of the content using the following syntax: Stsadm -o spsearch -action fullcrawlstart and see if your issue is resolved.

     

    Hope the information can be helpful

    -lambert


    Sincerely,
    Lambert Qin | Microsoft TechNet Managed Forum Support
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, September 29, 2009 3:47 AM

All replies

  • Hi,

     

    Because you recreate the farm and attach the content database, one possible reason is that the Search Server is not associated with the content database.

    Please make sure the Search Server is specified through: Central Administration > Application Management > Content Databases > Manage Content Database Settings

     

    After that, try to manually start a full crawl of the content using the following syntax: Stsadm -o spsearch -action fullcrawlstart and see if your issue is resolved.

     

    Hope the information can be helpful

    -lambert


    Sincerely,
    Lambert Qin | Microsoft TechNet Managed Forum Support
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, September 29, 2009 3:47 AM
  • ...also, are you using Forms authentication ?

    Serge Luca; blog: http://www.redwood.be
    Tuesday, September 29, 2009 11:11 AM