none
Can somone advise me on what version of .net to require for an application RRS feed

  • Question

  • I have an application that uses ClickOnce to install an application. I want to minimize user upgrades. I am trying to figure out if I need to specify a minimum version and if so what that minimum version as well as looking for an option to use whatever version is there.

    Thanks.

    Monday, February 18, 2013 8:18 PM

Answers

  • .NET Framework 2.0 and 3.0 come in Windows Vista, Windows 7 and Windows 8, so they would be the most universally available without user installation. However, I would guess that majority of Windows XP systems also have at least 2.0, 3.0 and 3.5 installed as many applications require .NET Framework support.

    The key question is, what is the minimum .NET Framework version your application can use? Have you tries retargeting you app to different .NET versions to see if there are issues?

    Monday, February 18, 2013 10:47 PM
  • You now have a completely different question: "Why does the application I developed not start after installation on a target system?

    As this issue appears not to be related to .NET Framework setup, but to click once deployment, please ask in the forum dedicated to that topic, here:

    http://social.msdn.microsoft.com/Forums/en-US/winformssetup/threads

    Wednesday, February 20, 2013 2:34 PM
  • Just specify the version your app needs. If you've developed NET 4.0 app it's unlikely it will run in the NET 2.0/3.5 framework.  Note that 2.0 -> 3.5 are essentially the same runtime with more framework classes added so they are "all the same" anyway, so it's not really an upgrade.

    Phil Wilson

    Saturday, February 23, 2013 6:44 PM

All replies

  • .NET Framework 2.0 and 3.0 come in Windows Vista, Windows 7 and Windows 8, so they would be the most universally available without user installation. However, I would guess that majority of Windows XP systems also have at least 2.0, 3.0 and 3.5 installed as many applications require .NET Framework support.

    The key question is, what is the minimum .NET Framework version your application can use? Have you tries retargeting you app to different .NET versions to see if there are issues?

    Monday, February 18, 2013 10:47 PM
  • I specified 2.0 and tried it on Windows/XP and it ran the installer said it was not installed and proceeded to install.  The install failed it said it could not install.

    I then tried my app again and it didn't indicate that an install was needed. The app loads but doesn't come up. It doesn't start the application.

    Wednesday, February 20, 2013 1:08 AM
  • I just tried it on XP. The application installs but it doesn't start.  How does one debug this?

    • Internet Explorer 8
    • Windows XP Professional Service Pack 3

    So I am getting failures on Windows 7 and Windows XP, Silent failures XP required .net 4.0, On Windows XP I specified 2.0.

    Wednesday, February 20, 2013 1:12 AM
  • You now have a completely different question: "Why does the application I developed not start after installation on a target system?

    As this issue appears not to be related to .NET Framework setup, but to click once deployment, please ask in the forum dedicated to that topic, here:

    http://social.msdn.microsoft.com/Forums/en-US/winformssetup/threads

    Wednesday, February 20, 2013 2:34 PM
  • Just specify the version your app needs. If you've developed NET 4.0 app it's unlikely it will run in the NET 2.0/3.5 framework.  Note that 2.0 -> 3.5 are essentially the same runtime with more framework classes added so they are "all the same" anyway, so it's not really an upgrade.

    Phil Wilson

    Saturday, February 23, 2013 6:44 PM