none
Need guidance publishing ASP.NET Core Application w/ WebAPI and React to Azure RRS feed

  • Question

  • I'm having some issues publishing my application to Azure. My project structure is the default structure scaffolded by Visual Studio. Each time I've tried to publish the application, the website url returns a blank screen. I've tried following different tutorials, but I'm still having the same issues. Do I need to change my project structure?
    Thursday, September 12, 2019 9:05 PM

All replies

  • Hi,

    Could you please navigate to the Kudu site and verify if the code has been published successfully.

    If yes, then are you able to browse the default page which is like sitename.azurewebsites.net/hostingstart.html?

    Can you also chck the default page of the project and try browsing it.

    Friday, September 13, 2019 4:21 AM
    Moderator
  • Hey,

    I didn't use Kudu, but looking at the App Service Editor within the Azure client, it appears that the code has been published successfully. Everything I try to browse to shows a 500 error. I published this directly from Visual Studio. I'm pretty lost on this because this is the first time I've used Azure. Do I need to go into launchsettings.json and change the application url there as well?

    Thanks

    Friday, September 13, 2019 7:12 PM
  • Can you please navigate to Kudu --> Debug console --> CMD.

    Click on site--> wwwroot and check if you have the pages published there.

    Also, try to add a "hello world" HTML page and try browsing the same. This is just to isolate the issue.

    Please let me know the results

    Tuesday, September 17, 2019 4:58 AM
    Moderator
  • Hey,

    I found the issue, it was an issue within my Startup.cs file. Seems to be working as expected after fixing this problem with my configuration. Thanks!

    Wednesday, September 18, 2019 3:33 PM