locked
Deploy services on different node RRS feed

  • Question

  • I have a problem deploying distributed application.

    I have my application(let's say orchestration service) with 3 partners : Lego drive, Lego Sensor, SimpleVision . I tried the tutorial step by step but I am using two different machines with different IPs but in the same network. So I use one node for the application and other node for the services. I configure the ports and IP addresses as said in the tutorial .

    I copy the deployment package in the other machine. I run the services and it works .

    I run the application but it doesn't work. I mean The robot is connected, The simlevision shows the picture. But the other machine on which application is supposed to run does not do anything. Apparently there cannot be a tcp socket connection . but the things is that I also cannot see my application in the browser. 

    Anyone has any idea what is the problem or what should I do ? has anyone tried this before to run on two different machine ? is there any thing tricky that I should change but I am not aware of ?

    Any help would be appreciated

    Thanks

    Saturday, April 6, 2013 3:12 AM

Answers

  • I hope you figured it out.

    I'm going to go ahead and close this thread, as there's been no activity for ten days...

    Feel to start up the discussion (with a new thread) if you need more help.

    Thursday, April 25, 2013 4:41 PM
    Moderator

All replies

  • Are you seeing any error messages when you start the orchastration service (or the node it runs in)?
    Monday, April 8, 2013 2:11 AM
    Moderator
  • No , it doesn't give any error message yet it doesn't work . I mean the application is supposed to receive a message from simple vision and command the robot to move . But nothing happens. it shows the dss node is running and the initialization services , but it doesn't show that the application is running too .
    Monday, April 8, 2013 3:19 AM
  • Hello,

    1) I'm trying to connect more or less the same services, one drive, one sensor and one simulation...Are your simpleVission a SimulationEngine Service? or what? because I want to use it but I don't know how to do it. 

    2) And about the ports, did you use http:/ IPcomputerA:50001/  and  http:/ IPcomputerB:50005/ or what ? because I had the same problem with another example that I did.  The services didn't show any problem but the application didn't run.

    Thanks.


    Monday, April 8, 2013 10:51 AM
  • Which tutorial are you following?
    Wednesday, April 10, 2013 7:29 AM
    Moderator
  • Service tutorial 11.


    Thursday, April 11, 2013 7:15 AM
  • Hi

    1) Actually for all services I am using the real world stuff . I have a LEGO and  a webcam. I did not try the simulation except playing with that ;)

    2)yeah , I exactly used the same way but for my services not for the tutorial services.

    Bryan has suggested this in my other post but it may solve my both problems

    " Two things that could be casusing this behavior:

    In RDS 4, by default DSS only listens on the loopback interface.  To connect from a remote computer you need to allow unsecured remote access as described here:

    http://msdn.microsoft.com/en-us/library/bb483066.aspx

    I also found that I needed to add a rule to my firewall allowing inbound TCP connections on the port the node is listening for http requests on.  How to open a port in Windows Firewall:  http://windows.microsoft.com/en-us/windows7/open-a-port-in-windows-firewall

    Please let me know if this solves you problem, and if it also addresses the issues you described here:

    http://social.msdn.microsoft.com/Forums/en-US/roboticsdss/thread/3425496d-2718-4350-bf82-1ac15676f6d4

    Bryan "

    To me it seams that it will work . I will try it to see what will happen. you can check it out too.

    Thursday, April 11, 2013 5:26 PM
  • Tutorial 11, Tutorial 7 and DSS deploy documentation
    Thursday, April 11, 2013 5:26 PM
  • it seems helpful.

    I'll try it this evening and I'll tell you if it works.

    Thanks!

    Friday, April 12, 2013 7:09 AM
  • Oh no! It doesn't work!!

    I'm doing something bad and I don't know what. Because I'm working with Service Tutorial 11... I want to run A and B in two differents computers... I reserved the ports, I allowunremoteAccess, and I opened a por in Windows Firewall, I don't see any problem, The service(B in the example) runs perfec, but the application (A in the example) doesn't.

    I think I'm connecting bad the ports... 

    I have to specify in A:   http://IPComputerA:50000 and in B http://IPComputerB:50000, being IPComputerA the IP from the computer where I run the A node, and IPComputerB , IP where I run B node?

    Thanks!


    Monday, April 15, 2013 3:11 PM
  • Have you tried inspecting the nodes remotely from a web browser?  What happens when you try this?
    Monday, April 15, 2013 5:55 PM
    Moderator
  • I hope you figured it out.

    I'm going to go ahead and close this thread, as there's been no activity for ten days...

    Feel to start up the discussion (with a new thread) if you need more help.

    Thursday, April 25, 2013 4:41 PM
    Moderator