none
Azure LogicApp Custom Connector on GET RRS feed

  • Question

  • I am evaluating Azure Logic app. I am trying to invoke a webserivce on SOAP. 

    I tried to use Logic App Custom connector to connect to this SOAP endpoint. 

    I am following the steps in the following page.  

    https://docs.microsoft.com/en-us/connectors/custom-connectors/create-register-logic-apps-soap-connector#get-support

    However, when I tried to edit the definition about 'GetOpenOrders', I aways got error when click 'Update Connector".

    I need to edit it to use 'GET' 

    In the response, do i need to manually define the sample output of Response of the GET operation? 

    I tried to edit 'response' body to import the json file I could think about based on the sample SOAP api. 

    But it constantly showed error message :

    {"Code":"BadRequest",

    "Message":"User policy with Operation:post UriTemplate:/GetOpenOrders not found in swagger.",

    "Target":null,

    "Details":[{"Message":"User policy with Operation:post UriTemplate:/GetOpenOrders not found in swagger."},

    {"Code":"BadRequest"},

    {"ErrorEntity":{"ExtendedCode":"14028",

    "MessageTemplate":"User policy with Operation:{0} UriTemplate:{1} not found in swagger.",

    "Parameters":["post","/GetOpenOrders"],

    "Code":"BadRequest",

    "Message":"User policy with Operation:post UriTemplate:/GetOpenOrders not found in swagger."}}],

    "Innererror":null}

    http://fazioapisoap.azurewebsites.net/GetOpenOrders

    Please give some advice. 

    Thanks

    M.
    Tuesday, June 16, 2020 4:09 PM