none
Visual C++ Compilers and .NET framework 4 RRS feed

  • Question

  • Hello, I need to install the Visual C++ Compiler (64bit) that comes with the Windows SDK (for Win 7). 

    The installer does not let me check the compiler box as "This feature is disabled because required .NET framework 4 not installed"

    However, .NET framework 4 is actually installed (to be sure, I've attempted to download it again; but the installation doesn't even start since it's already installed). Don't know enough about this type of issue to know what to try next. Any advice?

    Tuesday, July 28, 2015 7:24 PM

Answers

  • Thanks for the response. I'm running Windows 7 Pro, SP1, 64 bit. 

    I'm actually trying to install Theano (http://deeplearning.net/software/theano/install_windows.html#install-windows), which first requires me to install CUDA, which requires a Visual Studio installation to proceed.

    I wanted to download and install Microsoft Visual Studio 2010 Express, but I could only find Community instead. 

    Eventually, I will also be attempting to install Microsoft Visual C++ Compiler for Python 2.7, as well as a GCC installation, but for now I will try what you are suggesting first. 


    I'm reading Theano install instructions here: http://deeplearning.net/software/theano/install_windows.html#install-windows

    They appear to be out of date, as VS 2010 Express is no longer available to the public.

    Trying to use a different version, such as VS 2015 CE, is probably not going to work for you, as the C++ compiler provided is a completely different version.

    I suggest that you contact Theano support and ask them for procedures to install using a currently available Visual Studio VC++ version.

    The Theano community is here: http://deeplearning.net/software/theano/#community


    • Edited by pvdg42 Wednesday, July 29, 2015 2:18 PM
    • Marked as answer by pbbbbbbbb Wednesday, July 29, 2015 3:27 PM
    Wednesday, July 29, 2015 2:16 PM

All replies

  • Thank you for posting in MSDN forum.

    Some clarifications with you:

    What do you try to install, Visual C++ Express?

    What’s your OS version?

    As you may know, some .NET version is embed component of windows. If .net 4.0 is embed component of your system, you can try run “SFC /scannow” to repair the .NET first, refer to: https://support.microsoft.com/en-us/kb/929833

    To find out whether .NET 4.0 is installed on your machine and the installation status, we could use .NET Setup Verification Tool, you can download from here: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Running it, if .NET 4.0 in the dropdownlist, it means that .NET 4.0 is installed on your machine, and you can verify it to check whether it is installed correctly.

    You will find the log file under %TEMP% folder, see the first 15 lines and the last 15 lines.

    If the exit code != 0, it means that your .NET installed incorrectly, please first use .NET Framework Repair Tool to repair it, http://www.microsoft.com/en-us/download/details.aspx?id=30135

    If the exit code is 0, I think I need more information to troubleshoot, please use  http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to https://skydrive.live.com/ and share the link here.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, July 29, 2015 3:13 AM
    Moderator
  • Thanks for the response. I'm running Windows 7 Pro, SP1, 64 bit. 

    I'm actually trying to install Theano (http://deeplearning.net/software/theano/install_windows.html#install-windows), which first requires me to install CUDA, which requires a Visual Studio installation to proceed.

    I wanted to download and install Microsoft Visual Studio 2010 Express, but I could only find Community instead. 

    Eventually, I will also be attempting to install Microsoft Visual C++ Compiler for Python 2.7, as well as a GCC installation, but for now I will try what you are suggesting first. 

    Cheers, 

    pbbbbbbbbbbbbbb



    • Edited by pbbbbbbbb Wednesday, July 29, 2015 3:51 AM
    Wednesday, July 29, 2015 3:51 AM
  • Thanks for the response. I'm running Windows 7 Pro, SP1, 64 bit. 

    I'm actually trying to install Theano (http://deeplearning.net/software/theano/install_windows.html#install-windows), which first requires me to install CUDA, which requires a Visual Studio installation to proceed.

    I wanted to download and install Microsoft Visual Studio 2010 Express, but I could only find Community instead. 

    Eventually, I will also be attempting to install Microsoft Visual C++ Compiler for Python 2.7, as well as a GCC installation, but for now I will try what you are suggesting first. 


    I'm reading Theano install instructions here: http://deeplearning.net/software/theano/install_windows.html#install-windows

    They appear to be out of date, as VS 2010 Express is no longer available to the public.

    Trying to use a different version, such as VS 2015 CE, is probably not going to work for you, as the C++ compiler provided is a completely different version.

    I suggest that you contact Theano support and ask them for procedures to install using a currently available Visual Studio VC++ version.

    The Theano community is here: http://deeplearning.net/software/theano/#community


    • Edited by pvdg42 Wednesday, July 29, 2015 2:18 PM
    • Marked as answer by pbbbbbbbb Wednesday, July 29, 2015 3:27 PM
    Wednesday, July 29, 2015 2:16 PM
  • Well, that could explain the issues I've been having. Thanks. 

    P

    Wednesday, July 29, 2015 3:27 PM