none
Application Insights not collecting data RRS feed

  • Question

  • I have a Azure Web App and I have associated an Application Insights resource with it. Unfortunately it is not collecting any data. I have added the SDK via Visual Studio and later deleted the Application Insights resource and tried again. But still it not collecting any data.

    Here is the Application Insights associated with Web App

    And here is the overview blade of Azure Application Insights.

    Monday, August 19, 2019 3:43 AM

All replies

  • Hello Anuraj_P,

    Could you please make sure you have completed the steps in the standard troubleshooting guide?

    If the answer is not found there I do have some additional questions to try to track down the issue. First, where how is the app deployed? If it is in Azure, does App Insights pick up telemetry when running it in Visual Studio or is it always missing? Have you verified the Instrumentation Key is present and correct in your Web.Config or ApplicationInsights.config? It should have been added when you installed the SDK, though some templates require you to right click the project in VS and choose Add -> Application Insights.

    If you could share the configucation information in ApplicationInsights.json or your Web.Config that could provide some good insight.

    Finally, is there any custom configuration for App Insights that could be affecting data collection?

    Monday, August 19, 2019 6:56 PM
    Moderator