locked
inner activities fail, but final pipeline status is successful RRS feed

  • Question

  • I have a pipeline that executes about 1000 table copies within a for each loop and each day there are several failures, however, the trigger always reports successful.  I have a separate pipeline that is very similar to the first one and it's trigger always reports a status of Failure if it has an inner activity that fails.  The only difference is that the first one runs on a schedule trigger and the second runs on a window trigger.  Why wouldn't the first one also have a final status of Failure when an inner activity fails?

    ps I would take this up with support, but their support is the worst i have ever worked with in 20 years of development.


    • Edited by Nate45 Tuesday, October 15, 2019 1:08 PM
    Tuesday, October 15, 2019 12:52 PM

All replies

  • Hi Nate45,

    Thank you for your query. Could you please confirm if you are using "Execute pipeline" activity to execute inner activities in your Data Factory?


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered"Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.


    Wednesday, October 16, 2019 7:19 AM
  • Well from the errors it appears that there is a foreach activity and one of the activity inside that is failing . We need to understand more to figure why this is happening . Can you please provide some more details ? 

    Just in case if know have the resolution , please do provide the resolution here so that community can benefit from that . 


    Thanks Himanshu

    Thursday, October 17, 2019 3:59 AM
  • Yes, it is doing an ExecutePipeline that calls the a pipeline.

    The blue highlighted ForEach below is where the errors occur, however, like i said i have this exact pipeline running as a windowed trigger having the same failures, but reporting the pipeline as Failed.....as it should be.

    Here is the the pipeline:

    Thursday, October 17, 2019 2:37 PM
  • Thanks for the reply on this . Can you please let me know if "Wait on completion " is set for both the pipeline ?


    Thanks Himanshu

    Saturday, October 19, 2019 7:01 PM
  • Yes, "Wait on completion" is checked for each of the 4 "Execute Pipeline" activities.
    Sunday, October 20, 2019 12:33 PM
  • Hello , 

    For a deeper investigation and immediate assistance on this issue, if you have a support plan you may file a support ticket, else could you please send an email to AzCommunity@microsoft.com with the below details, so that we can create a one-time-free support ticket for you to work closely on this matter. 
    Thread URL:
    Subscription ID: 

    Run ID (for both successful and failed runs ) 

    Please let me know once you have done the same


    Thanks Himanshu


    Monday, October 21, 2019 9:08 PM
  • Please see my original post.  I have a paid support plan, but the issues we have submitted in the past never get resolved and are a colossal waste of time.  Its obvious it is outsourced to India and that group clearly has no knowledge or desire to resolve issues.  It is the only reason i decided to try here.
    Tuesday, October 22, 2019 12:22 AM
  • Hello Nate45 ,

    My sincere apologizes for the bitter experience .

    If you have any old support case # ( for this or any other issues ) , please do share  that with us , we will try to get the attention and help you out .


    Thanks Himanshu

    Wednesday, October 23, 2019 12:11 AM