none
MS Project 2010 can't open published schedule RRS feed

  • Question

  • Hello,

    I'm working on a MS Project Server 2010 and now I have a problem:
    One of our users has published a schedule, he can also open the schedule from the published version.

    I can't! open it.

    I see the schedule as usual etc click on open the sand clock is running about 30 seconds and then: nothing.

    Any idea?

    Thanks in advance.

    Br,

    Tobias

    Thursday, January 16, 2014 11:22 AM

All replies

  • Your project got corrupted.

    You have to check the project plan if any blank row id there or if resources are assigned to Summary task.

    Open corrupted project in MS Project connected to PS 2010 Prod env.
    2) Goto > Resource > Add Resource  > Build Team From Enterprise
    3) Check is there any local resource who has not replaced with corresponding enterprise resource. If yes then replace all those local resources with enterprise resource. If not then move to next step.
    4) Open resource sheet view and sort or filter by local resources.
    5) Then add few columns in resource sheet view like "Windows User Account, Email Address , Base Calendar etc".
    6) Now check has any local resource having enterprise attribute assigned to it, if yes then delete or assign local value as appropriate.
    7) Then GoTo > File > Save & Send > Save as project file > Save for sharing (at local location)
    8) Close project plan window and click "Yes" to save changes.
    9) Restart MS Project 2010 and open your project from local location.
    10) Then Goto > File > Save & Send > "Publish to Project Server". This will open "Import Project Wizard" to validate Resources and Task in Project.
    11) Then in Import Project Wizard window at left hand side click "Map Resource" to validate project resources.
    12) This will "Map Project Resource to Enterprise Resource " check all the resources highlighted with "Red" font and map "Standard" calendar to local resources.
           Note: Don't worry about local resource assigned "Standard calendar" but still highlighted "Red".
    13) Then click "OK" and click on "Continue to step 2" at bottom of "Import Project Wizard".
    14) Make sure you get number of errors 0 in step 2, else click on validate resource and take proper corrective action as explained in step 6.
    15) If you leave at least one resource as a local resource (unmapped to an enterprise resource), you will see the local resource in the Import Resource grid on the right side of the Confirm Resources page.          Examine the value in the "Import" column (if not able to see this column then insert this as new column) for the local resource .  The default value is "Yes", then change the value in the "Import" column          to "No", else system will import the local resource as an enterprise resource.
    16) Then "Continue to step 3, 4 and 5".
    17) Then at Step 5 , Save project to Project Server by clicking "Save as" link.
    18) Then publish the project to update the plan at PWA 2010.

    _______________________________

    OR 

    The “XML Round Trip” method:

    1. Open the project in MS Project.

    2. File, Save As, Save As File.

    3. When prompted select to save with “All Enterprise Custom Fields”.

    4. In the file dialog select the Save as type: XML


    5. Save the file to your local computer.

    image


    6. Once saved, close the project (don’t forget to check in!) and reopen the saved XML file, when prompted choose to import ‘As a new project’.

    7. Once opened, select Save As and save the project to the project server using the exact same project name.

    8. When prompted say yes to overwrite the existing project (you did check it in right?)

    9. Publish and your done



    kirtesh


    • Edited by Kirteshtiw Thursday, January 16, 2014 12:17 PM
    Thursday, January 16, 2014 11:34 AM
  • Hi tobias,

    • Indeed the file might be corrupted, then try the excellent advice of Kirsteshtiw in the post above (from a client from which you can open the file). 
    • You could ask to the user that can access the project to publish it again, both from MS Project and PWA.
    • Try also to publish by yourself the project plan through PWA.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Thursday, January 16, 2014 3:20 PM
    Moderator
  • If you've open the project before on your desktop maybe also look at the cache settings for this project. From Project Pro go to File > Options > Save > View Cache Status.  See it there are any errors.  Then try to remove this file from your local location Clean Up Cache > select the project > Remove from Cache.  Most caching issues have been resolved in the latest versions and service packs so try not to "Trash the Cache" too much.  Reoccurring cache problems may be a symptom of other problems.
    Thursday, January 16, 2014 6:45 PM
  • Hi,

    @kirtesh: If I want to save it as XML, MS Project crashes!

    @Guillaume: He published again - no change.

    @Joe: The cache was also was I was thinking about. I deleted everything - no change.

    Btw. if I open it on my Laptop (Win7) and not on my PC (Win XP) - then I can also open it without a problem.

    But: It takes around 2 minutes, because  of the hughness of the schedule (thousends of tasks and links to other schedules)...

    Br,

    Tobias

    Friday, January 17, 2014 3:02 PM
  • Hi Tobias,

    I'd say that thousands of tasks and links to other schedules are good factors for corrupting a file. Then such a huge file with interprojects links taking a long time to open, save and publish is quite normal.

    Maybe you could try to split it into several sub files and use a master project for consolidation. Then for inter-projects links, you should use the deliverables/dependencies, since you're working with Project Server 2010.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Friday, January 17, 2014 3:09 PM
    Moderator