Exchange 2007 - Client Access Role Install Fails


  • Hello,


    I am currently in the process of installing Exchange 2007 onto our server running Server 2003 Standard.  It has all Windows Updates and SP2 installed.


    The error we are getting is occurring during the initial setup process of the Client Access Role.  About 20 seconds after it starts to install the Client Access Role, it fails with the message "Error:  Process execution failed with exit code -1".


    A look in the ExchangeSetup.log file, show the following information:



    [08/06/2007 12:03:13] [1] Processing component 'Client Access Configuration' (Configuring Client Access role.).
    [08/06/2007 12:03:13] [1] Executing '$fullPath = [System.IO.Path]::Combine($RoleInstallPath, "ClientAccess\Owa\Bin\Microsoft.Exchange.Clients.Owa.dll"); $appBase = [System.IO.Path]::Combine($RoleInstallPath, "bin"); precompile-ManagedBinary -BinaryName $fullPath -AppBase $appBase;', handleError = False
    [08/06/2007 12:03:13] [2] Launching sub-task '$error.Clear(); $fullPath = [System.IO.Path]::Combine($RoleInstallPath, "ClientAccess\Owa\Bin\Microsoft.Exchange.Clients.Owa.dll"); $appBase = [System.IO.Path]::Combine($RoleInstallPath, "bin"); precompile-ManagedBinary -BinaryName $fullPath -AppBase $appBase;'.
    [08/06/2007 12:03:13] [2] Beginning processing.
    [08/06/2007 12:03:13] [2] Starting: C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\ngen.exe arguments: install "C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\Bin\Microsoft.Exchange.Clients.Owa.dll" /AppBase:"C:\Program Files\Microsoft\Exchange Server\bin"
    [08/06/2007 12:03:13] [2] Process standard output: Microsoft (R) CLR Native Image Generator - Version 2.0.50727.42
    Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
    Installing assembly C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\Bin\Microsoft.Exchange.Clients.Owa.dll
    Failed to find dependencies of image C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\Bin\Microsoft.Exchange.Clients.Owa.dll because of the following error: Strong name validation failed. (Exception from HRESULT: 0x8013141A)
    Compiling 1 assembly:
        Compiling assembly C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\Bin\Microsoft.Exchange.Clients.Owa.dll ...
    Error compiling C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\Bin\Microsoft.Exchange.Clients.Owa.dll: Strong name validation failed. (Exception from HRESULT: 0x8013141A)
    Strong name validation failed. (Exception from HRESULT: 0x8013141A)

    [08/06/2007 12:03:13] [2] Process standard error:
    [08/06/2007 12:03:13] [2] [ERROR] Unexpected Error
    [08/06/2007 12:03:13] [2] [ERROR] Process execution failed with exit code -1.
    [08/06/2007 12:03:13] [2] Ending processing.
    [08/06/2007 12:03:13] [1] The following 1 error(s) occurred during task execution:
    [08/06/2007 12:03:13] [1] 0.  ErrorRecord: Process execution failed with exit code -1.
    [08/06/2007 12:03:13] [1] 0.  ErrorRecord: Microsoft.Exchange.Configuration.Tasks.TaskException: Process execution failed with exit code -1.
    [08/06/2007 12:03:13] [1] [ERROR] Process execution failed with exit code -1.
    [08/06/2007 12:03:13] [1] Setup is halting task execution because of one or more errors in a critical task.
    [08/06/2007 12:03:13] [1] Finished executing component tasks.
    [08/06/2007 12:03:13] [1] Ending processing.



    I cannot seem to find any info on why this would be happening.  All other roles has installed successfully, it is just the Client Access that is giving issues.


    Any help/ideas would be greatly appreciated.



    Friday, June 08, 2007 12:15 PM

All replies

  • This is now solved - it needed Exchange 2007 Update Rollup 2 installing before the CAR would go on.

    Thanks to those who read the message - hope this comes in useful to someone...



    Monday, June 11, 2007 1:32 PM

    So does it mean that before upgrading to SP1 it is better to apply all the roll up patches


    Friday, March 07, 2008 3:21 PM
  • Worked for me too.  I was having the same problem and then installed Exchange 2007 Update Rollup 6 (current as of my install) and it worked.  Thanks for the help.  This was the only place I could find that even mentioned the error--and surprisingly a fix!!
    Monday, March 09, 2009 5:44 PM