none
Script error when loading map RRS feed

  • Question

  • I have some users that recently started experiencing a script error yesterday when loading bing maps in a .Net embedded map application and was hoping I could receive some direction on what the cause could be.  Our application has been unchanged for a few months now

    https://www.bing.com/rms/InternalControls/MapCoreBundle/cj.nj/cefa145b/f50a1a46.ja?bu=rms+answers+MapsSDK+AnonymousBegin*MapCore.en*M...

    https://www.bing.com/rms/InternalControlsPluginBundle/cj.nj/ede0e0f0/057baea1.js?bu=rms+answers+MapsSDKRelease+AnonymousBeing*Interna...

    I personally haven't been able to reproduce this myself yet.  Not sure if these two errors are generally timing problems? Any help would be appreciated

    Thanks

    Thursday, January 25, 2018 4:02 PM

Answers

  • It was happening in both IE and Edge.  I can no longer reproduce the problem though.  It appears it was fixed sometime yesterday
    • Marked as answer by kyle.anderson Wednesday, January 31, 2018 2:28 PM
    Wednesday, January 31, 2018 2:28 PM

All replies

  • Not aware of any issues and those URL's are simply the source code for the map control, so won't tell us anything. It's possibly a timing issue depending on how your application loads the map. Are you using the callback parameter in your map script URL?

    [Blog] [twitter] [LinkedIn]

    Friday, January 26, 2018 6:33 PM
  • Yes we are using the callback parameter.  I realize this is difficult without a full stack, I appreciate the reply.  I'm trying to get some more information. 

    Thanks
    Friday, January 26, 2018 7:10 PM
  • If I run the page with developer tools open, I get an error sj_evt is undefined.  It appears the problem has to do with loading the directions module.   The script error occurs while it is loading the directions module.  
    Friday, January 26, 2018 10:28 PM
  • https://www.bing.com/api/maps/sdkrelease/mapcontrol/isdk#directionsCreateDrivingRoute+HTML
    Click the play/run button, open developer tools and refresh the page you will see error sj_evt is undefined.  Looks like the error doesn't show up when viewing the main sdk page because there is a window.onerror handler. 
    Monday, January 29, 2018 2:18 PM
  • Just tested that sample in IE, Edge, Chrome and Firefox. Works great in all of them. I can't reproduce any issue. Which browser and version are you using?

    [Blog] [twitter] [LinkedIn]

    Wednesday, January 31, 2018 6:57 AM
  • It was happening in both IE and Edge.  I can no longer reproduce the problem though.  It appears it was fixed sometime yesterday
    • Marked as answer by kyle.anderson Wednesday, January 31, 2018 2:28 PM
    Wednesday, January 31, 2018 2:28 PM
  • I'm not aware of any changes occurring in the Bing Maps platform yesterday. Are you on a Windows Insider preview by chance? I noticed a number of issue in the Edge browser in the recent insider preview which might be related.

    [Blog] [twitter] [LinkedIn]

    Wednesday, January 31, 2018 11:09 PM
  • I am not on Windows Insider preview.  This was happening on IE 11/Edge  Windows 10/7/Server 2008 from what I saw
    Friday, February 2, 2018 3:37 PM