none
Access Report query prompts after save? RRS feed

  • Question

  • Note: I have checked the VBA and the grouping, they are not the issue so far.

    Hello all,

    My team and I are facing a strange issue that none of us can figure out, and we can't seem to find the answer anywhere. We've tried starting fresh and just about everything we could think of with no luck.

    Basically, we have a Report that has a named Query as a Record Source. When running this query, it works. However, if we open the Report, its VBA code, query, or anything related to it, and then save AT ALL (even just changing a comment or hitting save in general), we can no longer open or run the report because the query asks for two parameters. As stated, this query and report works flawlessly until a save is made. We've tried to compact and repair it, and we tried starting with a fresh file. All I need to do is insert one line of code in the report's VBA class, but we can't make any changes to the report, its VBA, or the query without it asking for the prompt. It works completely fine until a save, even if we change nothing.

    What would cause this? Also, I unfortunately cannot share the query or its code or anything from it due to it being classified information.

    Any help at all would be greatly appreciated. Thank you.

    Friday, October 12, 2018 2:55 PM

All replies