locked
help bytes RRS feed

  • Question

  • how read 

    ? ?

    in byte

    FF ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? 01 00 00 00 00 00 80 3F 00 00 0C 42 00 80 DD 43 00 00 00 00 00 00 5C 42 E8

    in new byte[]

    When replacing  ? ? to 0x00 not read how fix this

    Friday, September 13, 2019 2:10 AM

All replies

  • Hi programmervb.net,

    Thank you for posting here.

    As usual, we could not get ? in byte array. Then, how do you get the byte array that has some problems?

    I hope that you could tell me about it.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, September 13, 2019 3:26 AM
  • You can't really expect us to answer your question when we have no clue how you created that line.  If you're seeing ? when you print to the terminal, that usually means you are trying to print something as a character that isn't actually a valid Unicode character.

    By the way, the hex bytes following the ? symbols are single-precision floating point numbers.  There's an integer 1, then a floating point 1.0, then floating point 35.0.

    Show us your CODE, not your data.


    Tim Roberts | Driver MVP Emeritus | Providenza & Boekelheide, Inc.

    Saturday, September 14, 2019 6:53 AM