none
Uploading an app to the Windows Store RRS feed

  • Question

  • I have completed my first Windows 8 app, and now I’m trying submitting it in the Windows Store, everything went smooth until I got to the point where I need to upload the .appxupload package, here is my problem:

    I have used Visual Studio Ultimate 2012 to develop the app and associate the app with my Windows Store account and then created the .appxupload package through the Visual Studio, now when I try to upload the package to the Windows Store I always get an error message telling me that Windows Store is not able to read the package, and the message suggests to rebuild the package and then upload it again. I tried to rebuild and upload for more than 5 times, without any success except for one time.

    I have saved the package that was uploaded successfully to the Windows Store, but later I realized that I need to modify something in my app before submitting, so I did create a new package and got same error message when tried to upload, even now when I try to upload the previous successful package I’m getting the same error!

    This is really frustrating; I don’t know what is going wrong …. Any idea or advice in this regard …

    Thank you all


    Eng. Ash


    • Edited by Eng_Ash Tuesday, April 2, 2013 9:06 PM
    Tuesday, April 2, 2013 9:06 PM

All replies

  • A few of us are seeing the same thing, it appears Windows Store Dashboard has a bug right now and is not accepting appx uploads.

    Brandon Furtwangler

    Wednesday, April 3, 2013 12:00 AM
  • Has anyone got this working yet? I still can't upload anything except neutral packages.
    Wednesday, April 3, 2013 3:36 PM
  • I cant upload packages for x86, x64 and ARM.

    I tried rebooting my PC and even uploading it on my Surface RT. None worked 😐


    Its stuck at analyzing uploaded package for hours....
    • Edited by LastBattle Wednesday, April 3, 2013 10:24 PM
    Wednesday, April 3, 2013 10:23 PM
  • I managed to get it sorted. Not sure what fixed it in the end but this is what I did:

    • Completed my account registration, ensuring that the payment and tax sections of my store account were up to date.
    • Removed all packages from the packages folder
    • Cleaned my app from Build -> Clean "App Name"
    • Checked that I was building a Release version for Any CPU
    • I built the packages Project -> Store -> Create App Packages
    • Checked to build packages for upload to the Windows Store
    • Signed into my Store Account
    • I then selected the name of the App that I had previously reserved
    • I then selected Neutral - Release (Any CPU) as the package.
    • Once the package was created I was able to upload it (appname_release_AnyCPU.appxupload) to the store. I tool less than 60 seconds to upload and validate.

    Failing that I suggest you contact support (that's what I ended up doing) by clicking the support link from the top of your Dashboard.

    Good Luck.

    Wednesday, April 3, 2013 10:40 PM
  • I was able to get mine working today, i uploaded the same exact package as yesterday.  It just worked this time.

    I'm pretty sure they were experiencing technical difficulties on the backend yesterday.


    Brandon Furtwangler

    Wednesday, April 3, 2013 10:45 PM