none
Framework Client Profile Problem RRS feed

  • Question

  • Hi all,

    I'm using VS2008 + .NET Framework 3.5 SP1 but i cannot find the check box "Client-only framework subset" in the application tabs nor the compile tab. What I'm missing?

    Thanx
    Tuesday, June 23, 2009 7:50 AM

Answers

  • Hi M001es,

    Do you mean that you cannot find "Client-only Framework Subset" checkbox? (See Screenshot)


    If yes, have you upgraded Visual Studio 2008 to SP1?
    Developing application for the Client Profile is supported across all Visual Studio 2008 SP1 editions . Please go to Help menu >> About Microsoft Visual Studio to have a check.

    Thanks

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Wednesday, June 24, 2009 9:47 AM
    Wednesday, June 24, 2009 8:36 AM

All replies

  • Hi M001es,

    What kind of project are you developing now?

    Any WinForms or Windows Presentation Foundation project can be configured for the Client Profile.
    For more information, see: http://blogs.windowsclient.net/trickster92/archive/2008/05/21/introducing-the-net-framework-client-profile.aspx

    Please check the following steps to find the check box "Client-only framework subset":

    1. On the Project menu, click Properties
    2. Click the Compile tab.
    3. Click Advanced Compile Options.
    4. In the Target Framework (all configurations) list, select either .NET Framework 2.0, .NET Framework 3.0, or .NET Framework 3.5.
    5. If you want to develop for .NET Framework Client Profile, specify this configuration:
           - In the Target Framework (all configurations) list, select .NET Framework 3.5.
           - Select Client-only Framework subset.
    6. Click OK.
    7. In the Target Framework Change message that appears, click Yes.

    If it doesn't work, please feel free to let me know.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, June 24, 2009 7:35 AM
  • I've tried WPF and WindowsForms projects. I've followed all the steps but my problem is that the "Client-only Framework Subset" checkbox is missing.

    Thanks
    Wednesday, June 24, 2009 8:15 AM
  • Hi M001es,

    Do you mean that you cannot find "Client-only Framework Subset" checkbox? (See Screenshot)


    If yes, have you upgraded Visual Studio 2008 to SP1?
    Developing application for the Client Profile is supported across all Visual Studio 2008 SP1 editions . Please go to Help menu >> About Microsoft Visual Studio to have a check.

    Thanks

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Wednesday, June 24, 2009 9:47 AM
    Wednesday, June 24, 2009 8:36 AM
  • Thank you very much. The problem is I was using VS2008 (with no SP1) although NET3.5-SP1. I've upgraded the IDE and now the checkbox is there.
    Wednesday, June 24, 2009 9:45 AM
  • Hi M001es,

    I'm so glad to hear that. Cheer! :)
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, June 24, 2009 9:47 AM
  • In Visual Studio 2010 the .NET framework client profile target is much clearer.

     


    Janiv Ratson. Technology and Development Expert. | BL: http://blogs.microsoft.co.il/blogs/janiv/ | LI: http://www.linkedin.com/in/janiv | TW: http://twitter.com/janiv
    Tuesday, May 25, 2010 9:37 PM