none
eConnect Addapters RRS feed

  • Question

  • Hi

     

    I am farely new to BizTalk and have tried to setup a simple pipeline that sends (passthru) an eConnect xml schema to GP8 using eConnect 10 which I configured according to the eConnect manual. Whenever I execute my process I get the following error in the event log

    A message sent to adapter "BiztalkMessagingEngine" on send port "SendPort2" with URI "data source=sbp-sv3;initial catalog=PF001;packet size=4096" is suspended.

    Error details: The Messaging Engine failed to create the transport adapter "eConnect".

    OutboundAssemblyPath: "C:\Program Files (x86)\Common Files\Microsoft Shared\eConnect 10\Objects\Dot Net\Microsoft.Dynamics.GP.eConnect.BizTalk.Adapter.dll"

    OutboundTypeName: "Microsoft.Dynamics.GP.eConnect.BizTalk.Transmitter"

    Exception Details: "Could not load type 'Microsoft.Dynamics.GP.eConnect.BizTalk.Transmitter' from assembly 'Microsoft.Dynamics.GP.eConnect.BizTalk.Adapter, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'."

    MessageId: {7C191A66-269F-4749-B536-C3E152AF0A31}

    InstanceID: {BF253EB2-7218-42A9-B3B4-191EAB90855E}

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    Is there perhaps a training manual that I can purchase or any examples or tutorials regarding the eConnect adapters and their usage? I have searched everywhere for some info but can't find anything.

     

    Thanks
    Quinton

    Tuesday, August 21, 2007 9:09 AM

Answers

  •  

    I actually got it to work 2 days ago, have had the project on hold for a while. I got the eConnect 10 BizTalk adapters to process a SOP document in Dynamics GP8.

     

    What you need to do is get eConnect 10 and SP2 for it. Install both, then install the BizTalk adapters after you got SP2. To get the BizTalk adapeters go to add/remove program, select eConnect 10 and click on change, the BizTalk adapters will now be there. Make sure to install the eConnect 8 Business objects onto the database where your GP8 is installed.

     

    Then you add the eConnect adapter to your BizTalk group, be sure to select the host that has the eConnect adapter installed.

     

    I created a simple passthru file receive port , and a econnect passthru send port. I then added the receive ports name to the send ports filter. Took one of the sample messages from the eConnect 8 samples folder and droped it in, and it went through nicely :] sent it again and it moaned that the sopnumber or something already existed, so just changed the number and it worked.

    Thursday, July 31, 2008 6:41 AM

All replies

  •  

    Same problem here.  Did you resolve the issue?
    Wednesday, July 30, 2008 8:15 PM
  •  

    I actually got it to work 2 days ago, have had the project on hold for a while. I got the eConnect 10 BizTalk adapters to process a SOP document in Dynamics GP8.

     

    What you need to do is get eConnect 10 and SP2 for it. Install both, then install the BizTalk adapters after you got SP2. To get the BizTalk adapeters go to add/remove program, select eConnect 10 and click on change, the BizTalk adapters will now be there. Make sure to install the eConnect 8 Business objects onto the database where your GP8 is installed.

     

    Then you add the eConnect adapter to your BizTalk group, be sure to select the host that has the eConnect adapter installed.

     

    I created a simple passthru file receive port , and a econnect passthru send port. I then added the receive ports name to the send ports filter. Took one of the sample messages from the eConnect 8 samples folder and droped it in, and it went through nicely :] sent it again and it moaned that the sopnumber or something already existed, so just changed the number and it worked.

    Thursday, July 31, 2008 6:41 AM