none
Import Data Error RRS feed

  • Question

  • I am trying to use reader module to connect with the SQL server for data input. I have used microsoft data management gateway configuration manager. It is working perfectly (Connected to Cloud Service) and in Azure it is showing online as well. I have written a sample query like this, 

    SELECT 
    _MigrationHistory
    ,AnswerOptions
    ,Attachments

     FROM dbo.sample-test-db;

    to check the data input is working or not. But it is returning error like this, 

    requestId = 236eb4ee-01b7-4339-9952-1d815edc3dff errorComponent=Module. taskStatusCode=500. {"Exception":{"ErrorId":"InternalError","ErrorCode":"0000","ExceptionType":"ModuleException","Message":"Sorry, it seems that you have encountered an internal system error. Please contact amlforum@microsoft.com with the full URL in the browser and the time you experienced the failure. We can locate this error with your help and investigate further. Thank you.","Exception":{"ExceptionType":"Exception","Message":"Exception has been thrown by the target of an invocation.","Exception":{"ExceptionType":"Exception","Message":"Incorrect syntax near '-'.","Exception":{"ExceptionType":"Exception","Message":"transfer service job status is invalid.","Exception":{"ExceptionType":"Exception","Message":"The remote server returned an error: (400) Bad Request."}}}}}}Error: Sorry, it seems that you have encountered an internal system error. Please contact amlforum@microsoft.com with the full URL in the browser and the time you experienced the failure. We can locate this error with your help and investigate further. Thank you. Process exited with error code -2

    please help.

    Thursday, July 21, 2016 9:55 AM

Answers

  • Bipul, we are looking into a similar problem but we need your help a bit. could you try the following and let me know what you are observing?

    * run this query in another tool such as sql server management studio and see if you are getting any errors

    * try to include the identifiers such as the table name in " [ ]"

    * and see if your query still fails if you refer to other columns and tables that do not have _,- in their names?

     
    * could you also make sure dbo.sample-test-db is actually a table name and not the database name
    Friday, July 22, 2016 2:05 AM
    Moderator