locked
The web platform installer could not start RRS feed

  • Question

  • User482484332 posted

     Hi,

    This is the error that I get. Then it says 'Please report the following error to the web platform installer forum.

    I am running Windows 7 on a 64 machine and I have started the installer as an administrator.

    Thanks,

     

    Aad

    Thursday, October 7, 2010 6:40 AM

All replies

  • User-1689202383 posted

    Same thing for me today. Windows 7 64bit. I tried yesterday too with no luck.

    Thursday, October 7, 2010 11:02 AM
  • User-1209281366 posted
    Hi AadB1, sorry to hear about your problem. What version of webpi do you have on your machine? You can find the latest webpi v3 beta 2 at http://www.microsoft.com/web/webmatrix/download/ If that doesnt fix your problem - Can you post please the log files webpi has generated? You can find them in %localappdata%\Microsoft\Web Platform Installer\logs\webpi\ thanks, satish
    Thursday, October 7, 2010 1:50 PM
  • User-1689202383 posted

    I could not install the BETA either.

     

    Error: Unable to download the Web Platform product list from . Check your network connection and try again. If the problem persists, report the issue on the Web Platform Installer forum at: http://go.microsoft.com/fwlink/?LinkId=145244.

    Thursday, October 7, 2010 2:27 PM
  • User-1209281366 posted
    Thanks for reporting this. We are looking to get an inhouse repro for this. By then, can you kindly check if you are behind a proxy and if so, can you explicitly set the proxy settings in Internet Explorer? i.e., Open IE (as admin on Win7)->Tools->Internet Options->Connections->Lan Settings == Here uncheck the "Automatically detect settings" and check the "Use a proxy server". Then proceed to put the address and the port number for the proxy server. Save these settings. Try launching webpi again? thanks, Satish
    Thursday, October 7, 2010 2:32 PM
  • User-1689202383 posted

    I've tried both with Proxy on and off. Automatically detect settings was never selected.

    Thursday, October 7, 2010 2:59 PM
  • User-72997784 posted

    Experiencing the same issue here.

    Thursday, October 7, 2010 3:03 PM
  • User-1278494737 posted

    I got the same errormessage. Yesterday and because I thougt it could be an internet-problem today evening again.

    Always the message: "unable to download ... etc report the issue ... etc"

    Thursday, October 7, 2010 3:51 PM
  • User-1278494737 posted

    I tried it again and now a very funny message appears:

     "Newer version already installed"

    :-)

    Thursday, October 7, 2010 3:55 PM
  • User-162856161 posted

    Hi everyone

    I've noticed some unexpected behavior around SSL today - I'm seeing some secure connection errors generated when I'm running my already-installed copy of WebPI v3 Beta 2.  I've also noticed some other SSL sites loading more slowly/etc.  Some of these problems may be related to that (they are unfortunately, completely out of WebPI's control)

    Thanks

    Chris

    Thursday, October 7, 2010 3:57 PM
  • User-72997784 posted

    Looks like it's back for me now.

    Friday, October 8, 2010 10:39 AM
  • User1317015266 posted

    Same error for me on XP Pro 2002 SP3.

    Really need a resolution to this.

    Thanks

    Tuesday, October 12, 2010 11:52 AM
  • User-162856161 posted

    Is this a consistent error?  I had seen this intermittantly, but I can't get it to happen consistently.  Can you also post your latest log fle from here:

    XP, W2K3:           %USERPROFILE%\Local Settings\Application Data\Microsoft\Web Platform Installer\logs\webpi

    Thanks

    Chris<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>
    Tuesday, October 12, 2010 1:46 PM
  • User1317015266 posted

    This error is ocuring on launch of wpilauncher.exe so I don't have any log files to post.

    The web plantform installer is version 7.1.0949.01 WPI launcher

    Tuesday, October 12, 2010 1:58 PM
  • User1317015266 posted

    Sorry just found my latest log below - 

    DownloadManager Information: 0 : Loading product xml from: https://go.microsoft.com/?linkid=9744336
    DownloadManager Information: 0 : https://go.microsoft.com/?linkid=9744336 responded with 302
    DownloadManager Information: 0 : http://www.microsoft.com/web/webpi/3.0/webproductlist.xml responded with 307
    DownloadManager Error: 0 : Error downloading product file: 'System.InvalidOperationException: Url 'http://www.microsoft.com/web/webpi/3.0/webproductlist.xml' returned HTTP status code: 307
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.OpenUrlAndFollowRedirects(Uri& uri, IntPtr& hInetFile)
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.DownloadFile(Uri uri, String fileName, String& contentDispositionFileName)
       at Microsoft.Web.PlatformInstaller.ProductManager.DownloadFile(Uri url, String cacheFileLocation, DateTime productFileLastModified)
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory, Architecture architecture, Int32 majorOS, Int32 minorOS, Int32 majorSP, Int32 minorSP, Int32 osType)
    DownloadManager Error: 0 : Error loading cached XML file: System.IO.FileNotFoundException: Could not find file 'C:\Documents and Settings\peacockp\Local Settings\Application Data\Microsoft\Web Platform Installer\-1270117998.xml'.
    File name: 'C:\Documents and Settings\peacockp\Local Settings\Application Data\Microsoft\Web Platform Installer\-1270117998.xml'
       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
       at System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize)
       at System.IO.StreamReader..ctor(String path)
       at Microsoft.Web.PlatformInstaller.ProductManager.LoadFromXml(String xmlFile, Boolean loadEnclosures)
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory, Architecture architecture, Int32 majorOS, Int32 minorOS, Int32 majorSP, Int32 minorSP, Int32 osType)
    DownloadManager Information: 0 : https://go.microsoft.com/?linkid=9744336 responded with 302
    DownloadManager Information: 0 : http://www.microsoft.com/web/webpi/3.0/webproductlist.xml responded with 307
    DownloadManager Error: 0 : Error getting updated product file: System.InvalidOperationException: Url 'http://www.microsoft.com/web/webpi/3.0/webproductlist.xml' returned HTTP status code: 307
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.OpenUrlAndFollowRedirects(Uri& uri, IntPtr& hInetFile)
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.DownloadFile(Uri uri, String fileName, String& contentDispositionFileName)
       at Microsoft.Web.PlatformInstaller.ProductManager.DownloadFile(Uri url, String cacheFileLocation, DateTime productFileLastModified)
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory, Architecture architecture, Int32 majorOS, Int32 minorOS, Int32 majorSP, Int32 minorSP, Int32 osType)
    DownloadManager Error: 0 : WebClient download error: System.Net.WebException: The remote server returned an error: (401) Unauthorized.
       at System.Net.WebClient.DownloadFile(Uri address, String fileName)
       at Microsoft.Web.PlatformInstaller.ProductManager.WebClientDownloadFile(Uri url, String cacheFileLocation)
    DownloadManager Error: 0 : Web client download error: System.Net.WebException: The remote server returned an error: (401) Unauthorized.
       at System.Net.WebClient.DownloadFile(Uri address, String fileName)
       at Microsoft.Web.PlatformInstaller.ProductManager.WebClientDownloadFile(Uri url, String cacheFileLocation)
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory, Architecture architecture, Int32 majorOS, Int32 minorOS, Int32 majorSP, Int32 minorSP, Int32 osType)
    DownloadManager Error: 0 : Error loading product file: System.InvalidOperationException: Url 'http://www.microsoft.com/web/webpi/3.0/webproductlist.xml' returned HTTP status code: 307
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory, Architecture architecture, Int32 majorOS, Int32 minorOS, Int32 majorSP, Int32 minorSP, Int32 osType)
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory)
       at Microsoft.Web.PlatformInstaller.ProductServiceImpl.LoadProducts(String[] feeds)

    Tuesday, October 12, 2010 2:10 PM
  • User-162856161 posted

    Here is the error I see:

    DownloadManager Error: 0 : Error downloading product file: 'System.InvalidOperationException: Url 'http://www.microsoft.com/web/webpi/3.0/webproductlist.xml' returned HTTP status code: 307

    You seem to be hitting an error related to SSL - we are actively trying to figure out the root cause

    We have found that it is intermittant and if you try again, it very likely will report no errors

    Thanks

    Chris

    Thursday, October 14, 2010 3:35 PM
  • User-1696608031 posted

    The WPI runs perfectly fine, when you download the WPI and run it as an administrator.

    Cheers,
    Thomas

    Friday, October 15, 2010 6:34 AM
  • User1193897447 posted

    HI.I'm facing same problem.When you'll find solution then please  inform me at my addres beenishqundeel@gmail.com.Waiting 4 help.God bless you bye.

    none

    Saturday, October 30, 2010 3:45 AM
  • User1193897447 posted

    How i'll run WPI as an administrator?

    Saturday, October 30, 2010 10:17 AM
  • User-1209281366 posted
    Hi Ambee, to run WPI as administrator or a user with administrative priveleges, you can either - login as administrator/admin-user and launch wpi -or- you can press shift+right click on the webplatforminstaller exe and select "run as", then enter the user name password and launch the executable.
    Monday, November 1, 2010 1:40 AM
  • User-1151753060 posted

     I get the same message and running as administrator does not resolve the problem. I'm on vista.

    Wednesday, November 3, 2010 12:44 PM
  • User-162856161 posted

    Can you post the contents of the latest log file from here:

    Win 7 / Vista / 2008 :     %localappdata%\Microsoft\Web Platform Installer\logs\webpi

    Thanks

    Chris<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>
    Thursday, November 4, 2010 2:09 PM
  • User-1151753060 posted

    Chris,

    The only Web platform installer folder i can find is in c:\Program Files\Microsoft\Web Platform Installer and there is no log file present.

    Ross

     

     

    Thursday, November 4, 2010 3:35 PM
  • User-1151753060 posted

     ok found it:

     

    DownloadManager Information: 0 : Loading product xml from 'https://go.microsoft.com/fwlink/?LinkId=193533'
    DownloadManager Information: 0 : Product manager downloading: https://go.microsoft.com/fwlink/?LinkId=193533
    DownloadManager Error: 0 : Error downloading product file: 'System.Net.WebException: InternetOpenUrl returned 0x80072EFD: Unknown error 12029.
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.ThrowGetLastErrorException(String offendingFunction)
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.OpenUrlAndFollowRedirects(Uri& uri, IntPtr& hInetFile, String headers)
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.DownloadFile(Uri uri, String fileName, String& contentDispositionFileName)
       at Microsoft.Web.PlatformInstaller.ProductManager.DownloadFile(Uri url, String cacheFileLocation, DateTime productFileLastModified)
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory, Architecture architecture, Int32 majorOS, Int32 minorOS, Int32 majorSP, Int32 minorSP, Int32 osType)
    DownloadManager Information: 0 : Product manager downloading: https://go.microsoft.com/fwlink/?LinkId=193533
    DownloadManager Information: 0 : Product manager downloading: https://go.microsoft.com/fwlink/?LinkId=193533
    DownloadManager Error: 0 : WebClient download error: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:8777
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
       at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
       --- End of inner exception stack trace ---
       at System.Net.WebClient.DownloadFile(Uri address, String fileName)
       at Microsoft.Web.PlatformInstaller.ProductManager.WebClientDownloadFile(Uri url, String cacheFileLocation)
    DownloadManager Error: 0 : Error getting updated product file: 'System.Net.WebException: InternetOpenUrl returned 0x80072EFD: Unknown error 12029.
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.ThrowGetLastErrorException(String offendingFunction)
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.OpenUrlAndFollowRedirects(Uri& uri, IntPtr& hInetFile, String headers)
       at Microsoft.Web.PlatformInstaller.ManagedWinInet.DownloadFile(Uri uri, String fileName, String& contentDispositionFileName)
       at Microsoft.Web.PlatformInstaller.ProductManager.DownloadFile(Uri url, String cacheFileLocation, DateTime productFileLastModified)
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory, Architecture architecture, Int32 majorOS, Int32 minorOS, Int32 majorSP, Int32 minorSP, Int32 osType)'
    DownloadManager Error: 0 : WebException error loading product file: System.Net.WebException: InternetOpenUrl returned 0x80072EFD: Unknown error 12029.
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory, Architecture architecture, Int32 majorOS, Int32 minorOS, Int32 majorSP, Int32 minorSP, Int32 osType)
       at Microsoft.Web.PlatformInstaller.ProductManager.Load(Uri productFileUrl, Boolean filterByArchitectureAndOS, Boolean loadEnclosures, Boolean useCachedVersion, String cacheDirectory)
       at Microsoft.Web.PlatformInstaller.ProductServiceImpl.LoadProducts(String[] feeds)

    Thursday, November 4, 2010 3:42 PM
  • User-162856161 posted

    I'm seeing several network connection errors in your log - WebPI cannot seem to access the Internet.  Sorry if you covered this before - is your machine behind an authenticated proxy?

    Thanks

    Chris

    Wednesday, November 17, 2010 5:14 PM
  • User-373291317 posted
    Hi, Same problem here...... As Chris told us this is happening propably due to proxy server. The solution is : When WebApi Loads and show you what apllication you are trying to install (IIS and Webmatrix) ..... there are are links below the description which are pointing to Microsof download server. Click on them and see what will happen...if you cant access that page then surely it is a proxy server. So, use another proxy or use a connection without a proxy Cheers from Greece
    Friday, January 14, 2011 3:39 AM