GPSVC.dll x86 version - dependency walker error - side-by-side/manifest - VS2008


  • Hello, 

    I'm one of the seemingly thousands of people that is having side-by-side/manifest error with my debug version of my executable in vs2008 making it impossible to open.  I'm running 64 bit vista home premium.  I've tried everything including reformatting twice and downloaded every redistributable pacakage imaginable.  I've done all the /mt and linking stuff in the setting to no avail.  I've been running dependency walker on my debug executable(release .exe works) and it said msvcp90d.dll, msvcr90d.dll, gpsvc.dll were missing.  I then hunted down the msvc.dll's and put them in my folder.  dependency walker no longer complains about those missing.  However gpsvc.dll is another story.  this is the error I get right now with dependency walker...

    Error: The Side-by-Side configuration information for "c:\users\desktop\mybuild\game\GAME.EXE" contains errors. The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail (14001).
    Error: Modules with different CPU types were found.
    Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

    it also says under the CPU columnh it is for x64(the only dll that is not x86).  I'm assuming this is my error?  I've tried searching my comp for gpsvc.dll and found it but my comp only has the x64 one lying around.  Does anyone know how i can get the x86 version?  I've googled it numerous times and have found nothing.  Any other suggestions besides manually putting the .dll's into my project folder?  That seems lame because I'll have to do that for every project if this even works.

    Sunday, April 12, 2009 12:54 AM

All replies

  • Trying to make the Debug version work is pretty pointless, you can't get the debug version of the CRT libraries deployed.  Beware that Dependency Walker is running out of gas on modern executables, it knows nothing about manifests.  It will always show them as missing, even when they are not.

    You said the Release build works, stick with that one.  Gpsvc.dll is a DLL used for Group Policy, it is an operating system component.  Since you're running 64-bit, you'll only have the 64-bit version available.  It is pretty unlikely your program actually requires it, consider it just another glitch in Depends.
    Hans Passant.
    Sunday, April 12, 2009 12:23 PM
  • Well i would like to debug my programs. That would be slightly helpful to have debug working...  Also I use a script debugger that allows you to drop in a debug build in order to debug it.  This does not work in release version.  Hence why alterning release to be able to debug wont entirely fix everything, unless there's a way to still be in release and make it act entirely like debug?
    Sunday, April 12, 2009 7:58 PM
  • I don't follow.  Why don't you debug it on your dev machine?  Why use a "script debugger?"  We're talking about a C++ program, right?

    Hans Passant.
    Sunday, April 12, 2009 8:55 PM
  • Yes I'm talking about visual studios c++.  My program also has lua in it.  I use the debug .exe of visual studios to drop into a debugger for lua.  If the c++ debug .exe does not work properly neither will that that's all i'm getting at.  In other words I need the .exe from visual studios to work properly in order to get that functionality.  

    As of late the debug version does not work proberly in vs08.  Resulting in me not having propper debug info when stepping in my code in vs and not allowing me to use the other debugger.  All i was getting at in my last post is that it's inconveniant because of these reasons.
    Sunday, April 12, 2009 9:09 PM
  • I have this same problem. I am designing an embedded system and am unable to run the Debug version on the target (OS = Windows XP Embedded). Installing VS2008 on an embedded target is not an option and I can not run on a PC so there has to be a legit solution to this problem. Is there an install for just the Debug SxS DLLs?
    Thursday, November 05, 2009 1:15 AM
  • The two solutions for this case would be to either use it as a private assembly or to statically link.
    But remember, this is only for debugging and you should not distribute these files since it is agains the Microsoft terms.
    Visit my (not very good) blog at http://c2kblog.blogspot.com/
    Thursday, November 05, 2009 12:06 PM
  • For gpsvc.dll:

    gpsvc.dll Information:

    File Name: gpsvc.dll 

    File Description: Group Policy Client

    File Size: 593408 bytes 

    File Version: 6.1.7601.17514

    Creation Time: 9/25/2011 10:06:57 PM 

    File Path: %SYSTEMROOT%\WINDOWS\System32\

    To fix gpsvc.dll is missing error, you just need to download gpsvc.dll and save it to its path. To download gpsvc.dll, you can use DLLSuite. After gpsvc.dll is saved to your system, you can take the steps below to activate it.

    click Start, click Run, type Regsvr32 gpsvc.dll, press Enter and then restart your computer

    For msvcr90d.dll:

    It is a bug of MS systems. All of your hard disk format should be NTFS, and your VS2008 and the project should be saved under NTFS disks. You can open the link below to download the update package:


    If can't install, please upgrate your VS2008 to SP1, the download link is: http://www.microsoft.com/downloads/details.aspx?FamilyID=27673c47-b3b5-4c67-bd99-84e525b5ce61&DisplayLang=zh-cn

    For msvcp90d.dll:

    msvcp90d.dll information:

    Developer: Microsoft Corporation
    Product Name: Microsoft Visual Studio 2008
    File Version: 9.00.21022.8
    File Size: 848KB
    Description: Microsoft® C++ Runtime Library, 9.00.21022.8

    Any program developed by C will need msvcp90d.dll to run.

    Steps to fix msvcp90d.dll error

    Download msvcp90d.dll, and save it to %SYSTEMROOT%\WINDOWS\System32\, after that click Start, click Run, type Regsvr32 msvcp90d.dll, press Enter and then restart your computer.

    • Edited by DLLSuite Friday, October 14, 2011 4:10 AM
    Friday, October 14, 2011 4:10 AM