none
Net Framework updates, will not install RRS feed

  • Question

  • I have been having this problem for months and am asuming that it will become more of an issue. My system will not update my Net Framework 3.5 or any other Net framework. any help you can give me will be extremely appreciated!
    Stephen Meuse srkbiz
    Tuesday, December 20, 2011 4:17 AM

Answers

  • 1.0 Hotfix KB2572066 ---- Is this sufficent?

    Leave it alone for now.

    1.1 ----- Do I need to Uninstall this?

    Not unless you know the failing software uses that version

    2.0 SP 2 ----- this does need to be Uninstalled, Right?

    Yes, after you remove 2.0, then 3.0.

    3.5 SP1 ------ and this Uninstalled

    This is to be uninstalled FIRST, followed by 3.0 and then, 2.0.

    Now the cumulative installer covers everything? Just one Install?

    For 2.0, 3.0 and 3.5 only.

    And will this install cover the 1.1, if I have to uninstall it?

    No, that is a separate issue.

    As .NET Framework versions 1.0 and 1.1 are completely separate from .NET Framework 2.0/3.0/3.5, I do not recommend that you mess with them at all, unless you know for a fact that the software that is failing uses one of those two old versions.

    The cumulative installer I linked for you covers only 2.0, 3.0 and 3.5, plus SP's for those versions.

    Again, I gave you step by step instructions. Please follow them completely, in the correct order.

    Use Add/Remove... to remove .NET Framework 3.5, then 3.0 then 2.0 in that order.

    Ensure that all pieces of those versions are removed with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Once everything is removed, download this cumulative installer for .NET Framework 2.0, 3.0 and 3.5 with all updates through 3.5 SP1:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before running the installer from an account with full administrative priveleges, clear out your %temp% directory and disable your AV software.

    After the install, reverify as before.

     

    • Proposed as answer by Alexander Sun Wednesday, December 21, 2011 7:04 AM
    • Marked as answer by Alexander Sun Thursday, December 29, 2011 9:12 AM
    Tuesday, December 20, 2011 11:46 PM

All replies

  • Remove All Existing Framework and restart your System.

    there after install .Net framework 3.5 with SP1 is available from below link

    1) http://www.microsoft.com/download/en/details.aspx?id=22

    .net framework 4.0

    2) http://www.microsoft.com/download/en/details.aspx?id=17851&WT.mc_id=MSCOM_EN_US_DLC_DETAILS_121LSUS007996

    may be your problem solved.

     

     

     

    Tuesday, December 20, 2011 9:42 AM
  • We need to know your Windows version and service pack level in order to provide you useful suggestions.

    Why? Because .NET Framework versions 2.0, 3.0 and 3.5 come as part of the Windows 7 OS and cannot be removed. In Vista, .NET Frameworks 2.0 and 3.0 are part of the OS. So, before trying to remove any .NET Frameworks, please use this tool to identify .NET Framework versions on your system and verify their integrity:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Please post the first 20 lines and last 20 lines of tool output here:

     

    Tuesday, December 20, 2011 2:33 PM
  • I am running windows XP. Is this all that you needed or did you need the first and last 20 from each selection in the tool?

    ========================================
     it is not currently installed
    12/20/11,13:13:51] Section [Registry GE - .NET Framework 3.5 SP1 (Commo[12/20/11,12:59:46] Beginning of new SetupVerifier activity logging session
    [12/20/11,12:59:46] Activity log file location: C:\DOCUME~1\STEPHE~1\LOCALS~1\Temp\setupverifier_main_12-20-11_12.59.46.txt
    [12/20/11,12:59:46] Error log file location: C:\DOCUME~1\STEPHE~1\LOCALS~1\Temp\setupverifier_errors_12-20-11_12.59.46.txt
    [12/20/11,12:59:46] Build created on January 17, 2011
    [12/20/11,12:59:46] Detected operating system: Windows XP (x86)
    [12/20/11,12:59:46] Install state for .NET Framework 1.0: installed with service pack 3.
    [12/20/11,12:59:46] Install state for .NET Framework 1.1: installed with service pack 1.
    [12/20/11,12:59:46] Install state for .NET Framework 2.0: installed with service pack 2.
    [12/20/11,12:59:46] Install state for .NET Framework 3.0: installed with service pack 2.
    [12/20/11,12:59:46] Install state for .NET Framework 3.5: installed with service pack 1.
    [12/20/11,12:59:46] Install state for .NET Framework 4 Client: not installed.
    [12/20/11,12:59:46] Install state for .NET Framework 4 Full: not installed.
    [12/20/11,12:59:46] Not adding product '.NET Framework 1.1' because it is not currently installed
    [12/20/11,12:59:46] Not adding product '.NET Framework 2.0' because it is not currently installed
    [12/20/11,12:59:46] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [12/20/11,12:59:46] Not adding product '.NET Framework 3.0' because it is not currently installed
    [12/20/11,12:59:46] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [12/20/11,12:59:46] Not adding product '.NET Framework 3.5' because it is not currently installed
    [12/20/11,12:59:46] Not adding product '.NET Framework 4 Client' because it is not currently installed
    [12/20/11,12:59:46] Not adding product '.NET Framework 4 Full' becausen)] - stop parsing entries
    [12/20/11,13:13:51] Section [Registry GE - .NET Framework 3.5 SP1 (32-bit)] - start parsing entries
    [12/20/11,13:13:51] Section [Registry GE - .NET Framework 3.5 SP1 (32-bit)] - stop parsing entries
    [12/20/11,13:13:51] Not running action 'Registry GE - .NET Framework 3.5 SP1 (64-bit)' for product '.NET Framework 3.5 SP1' because the OS condition does not match
    [12/20/11,13:13:51] Not running action 'Registry GE - .NET Framework 3.5 SP1 (Wow6432Node)' for product '.NET Framework 3.5 SP1' because the OS condition does not match
    [12/20/11,13:13:51] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [12/20/11,13:13:51] ***WARNING*** File C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0\RedistList\FrameworkList.xml is not installed on the system
    [12/20/11,13:13:51] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [12/20/11,13:13:51] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [12/20/11,13:13:51] ExecutablePath = 'Netfx20TestApplication.exe'
    [12/20/11,13:13:51] FriendlyName = '.NET Framework 2.0 test application'
    [12/20/11,13:13:51] TimeoutSeconds = '300'
    [12/20/11,13:13:51] WaitOnExit = 'true'
    [12/20/11,13:13:51] Silent = 'true'
    [12/20/11,13:13:51] Launching process 'Netfx20TestApplication.exe' now
    [12/20/11,13:13:51] Process successfully launched. Waiting 300 seconds for it to complete.
    [12/20/11,13:13:51] Process 'Netfx20TestApplication.exe' exited with return code 0
    [12/20/11,13:13:51] Section [Files - .NET Framework netfxperf.dll] - start parsing entries
    [12/20/11,13:13:51] File C:\WINDOWS\system32\netfxperf.dll (version 4.0.31106.0) is installed on the system
    [12/20/11,13:13:51] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries
    [12/20/11,13:13:51] ****ERROR**** Verification failed for product .NET Framework 3.5 SP1


    Stephen Meuse srkbiz
    Tuesday, December 20, 2011 6:50 PM
  • What Service Pack level for XP? If you do not have SP3 for XP installed, you should do that.

    The last line of your tool output indicates that .NET Framework 3.5 is corrupt, which probably explains your update issues.

    .NET Framework 3.5 is an extension of .NET Framework 2.0, so in actuality, .NET Framework 2.0/3.0/3.5 is all one framework. Note that .NET Frameworks 1.0 and 1.0 are completely separate from 2.0/3.0/3.5 and don't need to be removed.

    I suggest the following:

    Use Add/Remove... to remove .NET Framework 3.5, then 3.0 then 2.0 in that order.

    Ensure that all pieces of those versions are removed with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Once everything is removed, download this cumulative installer for .NET Framework 2.0, 3.0 and 3.5 with all updates through 3.5 SP1:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before running the installer from an account with full administrative priveleges, clear out your %temp% directory and disable your AV software.

    After the install, reverify as before.

    Tuesday, December 20, 2011 7:24 PM
  • I did have SP3 installed already

    what I am showing in Add and remove programs is

    1.0 Hotfix KB2572066 ---- Is this sufficent?

    1.1 ----- Do I need to Uninstall this?

    2.0 SP 2 ----- this does need to be Uninstalled, Right?

    3.5 SP1 ------ and this Uninstalled

    Now the cumulative installer covers everything?  Just one Install?

    And will this install cover the 1.1, if I have to uninstall it?

    Thanks so much for your help with this!!

     


    Stephen Meuse srkbiz
    Tuesday, December 20, 2011 8:32 PM
  • 1.0 Hotfix KB2572066 ---- Is this sufficent?

    Leave it alone for now.

    1.1 ----- Do I need to Uninstall this?

    Not unless you know the failing software uses that version

    2.0 SP 2 ----- this does need to be Uninstalled, Right?

    Yes, after you remove 2.0, then 3.0.

    3.5 SP1 ------ and this Uninstalled

    This is to be uninstalled FIRST, followed by 3.0 and then, 2.0.

    Now the cumulative installer covers everything? Just one Install?

    For 2.0, 3.0 and 3.5 only.

    And will this install cover the 1.1, if I have to uninstall it?

    No, that is a separate issue.

    As .NET Framework versions 1.0 and 1.1 are completely separate from .NET Framework 2.0/3.0/3.5, I do not recommend that you mess with them at all, unless you know for a fact that the software that is failing uses one of those two old versions.

    The cumulative installer I linked for you covers only 2.0, 3.0 and 3.5, plus SP's for those versions.

    Again, I gave you step by step instructions. Please follow them completely, in the correct order.

    Use Add/Remove... to remove .NET Framework 3.5, then 3.0 then 2.0 in that order.

    Ensure that all pieces of those versions are removed with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Once everything is removed, download this cumulative installer for .NET Framework 2.0, 3.0 and 3.5 with all updates through 3.5 SP1:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before running the installer from an account with full administrative priveleges, clear out your %temp% directory and disable your AV software.

    After the install, reverify as before.

     

    • Proposed as answer by Alexander Sun Wednesday, December 21, 2011 7:04 AM
    • Marked as answer by Alexander Sun Thursday, December 29, 2011 9:12 AM
    Tuesday, December 20, 2011 11:46 PM