locked
Unable to publish Web App RRS feed

  • Question

  • Hi There,

    I initially had free subscription. After 1 month trial i changed the subscription to Pay-As-You-Go. Also had to reset my password.

    After the modification I am able to browse the Azure Portal. However i am unable to publish my web app to Azure using Visual Studio. I have reentered my password.

     

    Can anyone of you please help me with this as i am new to azure and pretty new to these things!!!!

     

    Thanks in advance.

    Monday, September 10, 2018 6:00 AM

All replies

  • Could you provide us the exact error message which you are getting, when trying to publish the web app using VS, might help us to rectify the issue properly?

    Also, kindly ensure that you're using the latest version of Azure SDK for .NET. If you have the current version installed, the Web Platform Installer lets you know that no installation is needed.

    Monday, September 10, 2018 8:22 AM
  • The problem is I dont get any error message. I sign in, and then nothing happens.

    Let me check the .NET Azure SDK version.

    Thank You

    Tuesday, September 11, 2018 3:31 AM
  • To Update,

    Today i tried to deploy using Publishing Profile, Got the below error:

    Severity Code Description Project File Line Suppression State
    Error Web deployment task failed. (Invalid URI: The hostname could not be parsed.) ASPCoreApplication_Teams 0

    Thank you

    Tuesday, September 11, 2018 4:01 AM
  • Try to reset publish profile and download the publisher profile. Downloaded profile contains your password in the userPWD variable. You could open the file with a text editor and check the password. Then try it again and see if it helps. To reset publisher profile, you may go to Portal -> Click on Web App -> Click on “Reset publish profile” in Overview section. You may refer to the below screenshot,

    Reference: https://blogs.msdn.microsoft.com/kaushal/2013/05/29/windows-azure-web-sites-reset-your-deployment-credentials-vs-reset-your-publish-profile-credentials/

    Wednesday, September 12, 2018 7:51 AM
  • To help isolate the issue I'd try the following in any order. 

    1. Try to deploy a basic template web app created in VS using the publish profile. This rules out any issues with the code compiling prior to deployment.

    2. Log out of everything in Visual Studio (Cloud Explorer, and the account in VS -> top right hand corner of the window), close VS, reopen it, and log back in. I've seen issues in the past where the account didn't sync correctly until all accounts were removed and then accessed again. 
    Friday, September 14, 2018 2:41 PM
  • Checking in to see if the above answer helped to solve your problem. Let us know if there are still any additional issues we can help with. 

    Sunday, September 16, 2018 8:58 AM
  • Hello,

    I tried the first point but it is still failing. I am unable to even redeploy a solution which i had published earlier.

    Regarding Visual Studio Login, i have not logged in using any account. Mine is a desktop version and accessing azure subscription only during publishing the web app.

    Tuesday, September 18, 2018 9:13 AM
  • I tried creating a new resource group/web app and hence a new publishing profile. Still the publishing of Web App is failing.
    Tuesday, September 18, 2018 9:14 AM
  • I haven't seen this error before so could you provide a screenshot of where the error and at what stage you are in the deployment? I need a little more context as to where this is failing.
    Wednesday, September 19, 2018 1:20 AM