locked
Visual Studio IntelliTrace issue with capturing large Linq queries RRS feed

  • Question

  • Visual Studio Ultimate IntelliTrace dose a fine job capturing generated SQL from small Linq queries. However with large Linq queries, the generated SQL in the IntelliTrace Window is always cutoff with two messages regarding this:

    --  The data may be truncated and may not represent the query that was run on the server

    --  Command text may be incomplete and it may cause syntax errors. This is likely because the text was too large.

    I have tried to modify the collectionplan.xml maxsize: 

    <DataQuery index="0" maxSize="40960" ></DataQuery>

    But this did not help

    Sql Server Sql profiler can capture the entire Sql statement. Is there a remedy for this? Thanks

    Thursday, December 26, 2019 4:42 PM

All replies

  • Hi gariani,

    Welcome to MSDN forum.

    According to your description, you could go to Tools|Options|Intellitrace|Intellitrace Event, then enable event what you need to collect. Besides, you could also set larger number to check if the issue persists.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, December 27, 2019 3:34 AM
  • Dylan;

    Thank you for your response. However the problem is not catching the events that I want, but the fact that the result is cut of due to intellitrace truncating it. Could you elaborate what you meant by:

     "you could also set larger number to check if the issue persists"

    Thanks

    Wednesday, January 1, 2020 5:34 PM
  • Hi gariani,

    Thank you for reply.

    It means that you could try to set bigger "maxSize", for example 524288 or more.

    And you could also go to Tools|Options|Intellitrace|Advanced, set disk space to "no size limit"

    If it still doesn't work, you may go to Tools|Options|Intellitrace|General to disable "Enable Intellitrace" option, and sorry for it brings this inconvenience.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, January 2, 2020 3:38 AM
  • Dylan;

    Thanks for taking the time to answer. Unfortunately  setting the disk amount to No Size Limit did not help and queries are still being truncated. 

     


    • Edited by gariani Friday, January 3, 2020 1:47 AM
    Friday, January 3, 2020 1:47 AM
  • Hi gariani,

    Thank you for feedback.

    It seems to be a internal limitation of intellitrace. We recommend you could go to Help|Send Feedback|Report a problem in VS IDE, then report it to product team, and product team experts will response to you as soon as possible.

    BTW, you could also share the link here, if there are other community with same issue, which would help you vote it.

    Wishing you a happy New Year.

    Best Regards,

    Dylan



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, January 3, 2020 9:12 AM
  • Thank you Dylan will do
    Thursday, January 9, 2020 12:32 AM
  • Estimado pudo resolver este inconveniente al momento de capturar el SqL? estoy con el mismo problema y cualquier información sera de mucha ayuda.. gracias
    Sunday, August 16, 2020 10:53 PM