locked
NMAKE : fatal error U1077: '"path\cl.exe"' : return code '0xc0000135'

    Question

  • I am trying to compile a .c function that gets hooked to a CFD program.  When the makefile generated by the CFD program invokes "NMAKE" to compile the function I get the following error:

    NMAKE : fatal error U1077: '"path\cl.exe"' : return code '0xc0000135'

    The source code of the function appears sound.  It is a very simple function.  My best guess is something is wrong in my environment setup or something is wrong with the Visual installation.

    Can anyone shed some light on what might be the cause of that fatal error? Any suggestions/help would be much appreciated.

    Tuesday, September 26, 2006 10:58 PM

Answers

  • It looks like the makefile does not have the path to where your compiler is installed.  You might want to review the generated makefile and see what kind of environment variables or other parameters it expects to have set or customized so it can find the command-line compiler, the linker, and other programming-system utilities that may be needed. 

    You can get general help about nmake from the MSDN Help in VC++ and on-line.  For what the CFD program generates and how to setup an environment that is expected in the generated makefile, you'll need to consult with CFD experts, on-line sources and any documentation. 

    Good luck,

     - Dennis

    Wednesday, September 27, 2006 5:16 AM

All replies

  • It looks like the makefile does not have the path to where your compiler is installed.  You might want to review the generated makefile and see what kind of environment variables or other parameters it expects to have set or customized so it can find the command-line compiler, the linker, and other programming-system utilities that may be needed. 

    You can get general help about nmake from the MSDN Help in VC++ and on-line.  For what the CFD program generates and how to setup an environment that is expected in the generated makefile, you'll need to consult with CFD experts, on-line sources and any documentation. 

    Good luck,

     - Dennis

    Wednesday, September 27, 2006 5:16 AM
  • I got this error when I am using a 32 bit lib.

    I resolved this by setting the environment variable "lib" to point to a 64 bit lib dir as below.

    C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib\x64

     

    set lib=C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib\x64;your/other/lib

     

    hope this helps.

     

    Friday, September 12, 2008 12:30 AM

  • I had the same error when I forgot to launch vcvarsall.bat before compiling from Dos.

    Maybe cl.exe finds wrong libraries when the Paths are not good.


    • Proposed as answer by mahmoodn Sunday, December 28, 2008 6:51 PM
    Sunday, September 21, 2008 12:04 AM
  • I also got this error code when configuring QT 4.4.3 in windows and the solution is truly run VCVARSALL.BAT before CONFIGURE.exe.

    Thanks,

    "I use VC++ 8.0"
    Sunday, December 28, 2008 6:51 PM
  • Please try "cmd", then "cl", you  will see the reason of the error.
    The reason is the system environment set is not right.
    • Proposed as answer by Vibz90 Wednesday, May 23, 2012 8:40 AM
    • Unproposed as answer by Vibz90 Wednesday, May 23, 2012 8:40 AM
    Wednesday, October 21, 2009 1:59 PM

  • I had the same error when I forgot to launch vcvarsall.bat before compiling from Dos.

    Maybe cl.exe finds wrong libraries when the Paths are not good.



    Quick note, as I just found this thread when I got the error myself trying to build OpenSSL, the BAT file is called vsvars.bat for me, and I found that I have to run it *from within the DOS box* to get it to work. It sets the path temporarily for the session - but because the DOS box it generates opens and closes immediately, the changes are lost. If you run it from within DOS, and do everything you need to do before closing the DOS box, it should work perfectly.
    Jason Teagle
    Saturday, March 27, 2010 6:16 PM
  • Very, very, VERY good hint !!!!!
    Monday, February 28, 2011 10:17 PM
  • for me the issue was path for these dll was not correct msobj80.dll, mspdb80.dll, msvcp80.dll, msvcr80.dll.

    when i run cl from cmd prompt i came to know about this. after setting the path issue got resolved.

    thanks for info. :)

    Wednesday, June 8, 2011 2:56 PM

  • I had the same error when I forgot to launch vcvarsall.bat before compiling from Dos.

    Maybe cl.exe finds wrong libraries when the Paths are not good.



    Quick note, as I just found this thread when I got the error myself trying to build OpenSSL, the BAT file is called vsvars.bat for me, and I found that I have to run it *from within the DOS box* to get it to work. It sets the path temporarily for the session - but because the DOS box it generates opens and closes immediately, the changes are lost. If you run it from within DOS, and do everything you need to do before closing the DOS box, it should work perfectly.
    Jason Teagle

    ^ Works.  Many thanks.
    Thursday, August 18, 2011 5:03 PM
  • hello by running vcvars32 in cmd the problem solved but i m installing htk toolkit but as nmake execute it gives error link 1181  error problem and return code 0x49d

     

    Friday, November 18, 2011 2:58 PM