ACS Auth for Facebook ID provider RRS feed

  • Question

  • Hi, I am trying to use FB as a identity provider (i am able to use google, yahoo etc., fine). but I am not sure if I registered the "abc.cloudapp.net" site under the facebook app correctly. FB is throwing an error Given URL is not allowed by the Application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

    I created a FB app -- I put the site URL as below.  appreciate if someone could help. I am not sure if the domain I entered is correct?  the app is hosted in azure and I go to URL as http://abc.cloudapp.net

    Wednesday, April 17, 2013 2:47 PM


All replies

  • Hi,

    Facebook doesn't like the request for authentication because it has no idea who the requestor is.  Therefore you need to tell Facebook about my application.


    Here is the official guide for configuring Facebook as an Identity Provider:




    QinDian Tang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, April 18, 2013 5:20 AM
  • Thank you Qin. this is very helpful.  It seems that I didn't put the ACS namespace in the FB site URL. After I made the change, my site is able to authenticate however, it still return to the login page! All other identity providers are working and correctly logs in the user to the site! 

    Question: Do i need to enter the site url in the Page Tab or remove? 

    for App domain - what will be value - Is it like *.cloudapp.net or abc.cloudapp.net or blank? 

    Appreciate your help. Thanks

    Thursday, April 18, 2013 2:37 PM
  • Hi,

    Try with this:

    App domain: accesscontrol.windows.net

    Site URL: https://abc.accesscontrol.windows.net

    The site url is your namespace of ACS, you can get it from the acs page from portal (adding with "https://").


    QinDian Tang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, April 19, 2013 2:22 AM
  • you need to have a page name configured for FB site url

    something like abc.cloudapp.net/somepage or abc.cloudapp.net/somepage.aspx or similar this is where facebook will return the results of auth

    Vishal Narayan Saxena http://twitter.com/vishalsaxena

    Friday, April 19, 2013 9:14 PM
  • My site is accessed as http://www.abc.cloudapp.net - I can try with home.aspx but where would you configure this. In the Facebook App settings?  
    Friday, April 19, 2013 9:24 PM
  • Thanks Qin. I tried with these settings. it's still returning me to the Login page. I wonder if my facebook app has to be approved for FB App center listing.  From the App Details page I have this "Your App Detail page is live and available in search"  

    Do I need to put anyting in the FaceBook (not in ACS page where I put email as permission)  for the permissions? 

    Friday, April 19, 2013 9:40 PM
  • Hi CRM elite,

    here are settings that I have on my settings page, hope this helps

    Vishal Narayan Saxena http://twitter.com/vishalsaxena

    Saturday, April 20, 2013 1:37 AM
  • pretty much the same settings that I have but still no luck (except that I had https://abc.accesscontrol.windows.net  (offcourse I tried with /home.aspx as well). 

    Sandbox Mode
    Listed Platforms
    Website with Facebook Login

    Saturday, April 20, 2013 3:15 AM
  • not sure what might be going on, can you try to isolate the issue by creating a new dotnet app (dummy app that you can share code of here on forum), create a new test facebook account and do the settings, if problem persist share it on this forum and we can take a look, 

    I hope with this small troubleshooting exercise we will be able to find out differences between this test app and your real app and may be able to pin point the issue

    btw, just thinking loud, that you can also try this whole setup on local machine website, you dont have to deploy online to test faceboook authentication, facebook supports localhost:port address in the callback url

    Vishal Narayan Saxena http://twitter.com/vishalsaxena

    Monday, April 22, 2013 10:39 PM
  • CRM elite,

    Your issue requires some interactive troubleshooting, please open a support ticket with Microsoft.


    Note: Select "technical and billing support" section from the above link and then click "Get support".

    Best Regards,


    Tuesday, April 23, 2013 2:51 PM