none
Clustering does not show all pushins/clusters in portrait mode RRS feed

  • Question

  • In portrait mode, the clustering module from Bing Maps v8 does not show all clusters and pushpins. I originally saw the problem on Android/iPhone, but I've also been able to reproduce it in Chrome with the sample provided by popping it out and changing the window size: https://www.bing.com/api/maps/sdkrelease/mapcontrol/isdk#clusteringMeanAverage+JS.

    Here are two screenshots, one landscape and one portrait that shows the issue. The landscape has the expected result and the portrait is missing a few rows of pushpins. Can I do anything to prevent this from happening, any quickfix?

    Thanks!

    Tuesday, May 23, 2017 9:59 AM

Answers

  • This issue has been fixed in the experimental branch. Add &branch=experimental to test. The main release branch will be updated with this fix at the end of the month.

    [Blog] [twitter] [LinkedIn]

    • Proposed as answer by Ricky_Brundritt Tuesday, May 23, 2017 2:46 PM
    • Marked as answer by LambdaFun Tuesday, May 23, 2017 2:49 PM
    Tuesday, May 23, 2017 2:45 PM

All replies

  • This issue has been fixed in the experimental branch. Add &branch=experimental to test. The main release branch will be updated with this fix at the end of the month.

    [Blog] [twitter] [LinkedIn]

    • Proposed as answer by Ricky_Brundritt Tuesday, May 23, 2017 2:46 PM
    • Marked as answer by LambdaFun Tuesday, May 23, 2017 2:49 PM
    Tuesday, May 23, 2017 2:45 PM
  • When will this patch go live? I do not believe this fix has been deployed to the release branch yet.
    Tuesday, June 13, 2017 9:59 PM