locked
Azure - cloud service - publish - error RRS feed

  • Question

  • Hi,

    I always used azure website to host my application, but I have a problem with azure website and devexpress, with the azure cloud service this problem should vanish.

    So I tried to publish my application as cloud service. I created a new cloud service and followed the configuration wizard. The publish runs without any problem. Also the installation works, but if I start the app I get following error:

    I do not know but maybe it has something to do with the https signature. In the confiugration wizard I created my own signature. When I start the application in the browser it looks like this:

    Thanks.

    Markus

    Tuesday, March 26, 2013 9:38 AM

All replies

  • Hi,

    ok, now I know that if I use a self-signed certificate for https a desktop app will not run and that I can enable unencrypted access after publishing. But where in the azure configuration I can enable unencrypted access?

    Where can I get a signed certificate to use the https connection?

    Thanks.

    Markus

    Tuesday, March 26, 2013 2:16 PM
  • I have written up the following blog post:

    How to Run a LightSwitch App in Azure without HTTPS (V3 Apps Only)

    Note that as the title implies, this only applies to "V3" apps, i.e. apps that contain an HTML Client or a Silverlight client that has been upgraded using "Right-click >> Upgrade Project" (on the LS project in the solution explorer).

    Another alternative to this would be to publish to an Azure Web Site instead of a Cloud Service.  These can be configured with or without HTTPS and there is no need to manage any certificates.


    David Kidder | Senior SDET | Microsoft | LightSwitch

    Friday, March 29, 2013 3:29 PM
    Moderator
  • @Dave, @Brian - guys can we give Markus a chance to confirm if Dave's reply addresses his question. While I have no doubt that Dave's answer is completely technically correct, for a V3 application, we don't know if this has helped Markus with his issue or not. With the thread marked as answered, many people won't bother even looking at it, & a potential answer could be lost.

    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    Please click "Mark as Answer" if a reply answers your question. Please click "Vote as Helpful" , if you find a reply helpful.
     
    By doing this you'll help others to find answers faster.

    Sunday, March 31, 2013 8:03 AM
    Moderator
  • Hi,

    @ Dave, thanks for the answer and the blog post.

    @Yann, thanks. Yes, this is not really the answer for my question, because I cannot upgrade my project from 2012 to V3, because my extensions does not work with the upgrade. For details see this thread.

    Is it also possible to host a 2012 project without https?

    My main problem is that there is a problem with devexpress report extension and azure website

    So I tried to publish as cloud service, but I have no experience with SSL Certificates etc as Lightswitch delevoper. For me Azure Websites was really good, because it is really easy to publish.

    A blog post for lightswitch developer about how to configure a domain with SSL certificate etc. would be very good.

    Thanks.

    Markus

    Monday, April 1, 2013 10:48 AM
  • @Markus - It is not possible to host a 2012 RTM project deployed as an Azure Cloud Service without HTTPS.

    I will get the info on using an SSL cert with a LightSwitch app condensed and posted.

    Is there any reason why you cannot use an Azure Web Site instead of a Cloud Service?  Azure Web Sites are "pre-configured" to enable HTTPS, so when you publish a LightSwitch app to them, you only need to specify "HTTPS" and don't worry about the cert at all.  Azure Web Sites are also the easiest target to publish a LightSwitch app to.

    Easily Deploy Your LightSwitch Apps to Azure Websites in Minutes


    David Kidder | Senior SDET | Microsoft | LightSwitch

    Monday, April 1, 2013 2:08 PM
    Moderator
  • Hi,

    thank you for the answer Dave.

    A post about using SSL would be very good.

    I published my apps to Azure Website and it worked really good until last monday. Since Monday the export to pdf function from devexpress does not work any more. I create all my reports on server site with the export to pdf function. This is the reason why I need this function! The devexpress team wrote that there is a problem with azure website and devexpress xtrareport and they do not know why it is and if they will solve the problem. Devexpress wrote that the only way is to use azure cloud service instead of azure website.

    Thanks.

    Markus

    Monday, April 1, 2013 3:19 PM
  • @Markus, is there a specific DevExpress forum post that you were on for this?  I found this one Export to PDF on Azure - red rectangles are shown in the PDF file

    I'd like to get some more info from them on what the issue is.  Also, did you change something last Monday?  Install a new version of DevExpress?


    David Kidder | Senior SDET | Microsoft | LightSwitch


    Monday, April 1, 2013 3:33 PM
    Moderator
  • Hi,

    I have a private post in the devexpress forum, but the devexpress team just give me as answer the post you already found.

    I have nothing changed in the application. The application was published a month before and was running without any problem all the time.

    I have already opened a ticket about this in the lightswitch forum: Devexpress export to pdf - RED X

    Thanks.

    Markus


    Monday, April 1, 2013 3:39 PM
  • Hi,

    here a screenshot from the answer I got from devexpress support.

    Monday, April 1, 2013 3:47 PM
  • @Markus - that's what I suspected, & was why I unmarked Dave's reply. If any future reply does qualify as the answer to your question, please make sure to mark it as such.

    You're the one who should get to decide what, if any, replies answer your question.


    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    Please click "Mark as Answer" if a reply answers your question. Please click "Vote as Helpful" , if you find a reply helpful.
     
    By doing this you'll help others to find answers faster.

    Tuesday, April 2, 2013 11:52 PM
    Moderator
  • @Yann, ok. For me it was an answer that it is not possible to host a 2012 app without hhtps. But I am going to wait a little bit, because I did not get an answer from Dave about the Devexpress Extension and Azure Website. I hope this is ok?

    Thanks.

    Markus

    Wednesday, April 3, 2013 11:02 AM