none
How can config memory for application process used more than 4 GB in Windows 2003 Server R2 ENT. RRS feed

  • Question

  • When the process of application want to used more 4GB. How i can config ?
       1.Operating system is Windows 2003 Server R2 Ent. 32 Bit.
       2.Physical Memory is 16GB
       3.This Server is Metadata has the SAS Process Running
       4.Edit Boot.ini for PAE Mode and OS can see 16 GB (Full Physical Memory)
       5.SAS Process in this site want to used more 4GB 
       6.Monitor SAS Process in taskmanager see over 3 GB and alway hang.
    How can i config this case to used more 4GB.Please help me to solve this problem. Thank you.
       

    Wednesday, September 2, 2009 3:48 PM

Answers

  • hi,

    You should enable PAE (Physical Address Extension) in your OS for the
    applications to use more than 4 GB of "physical memory" when your system
    has > 4 GB RAM. This prevents swapping of page file contents under memory
    pressure.

    Please refer to this KB article for more details.

    http://support.microsoft.com/default.aspx/kb/283037

    Thanks!
    Nikhil
    • Marked as answer by SupachaiS Monday, September 7, 2009 2:29 AM
    Wednesday, September 2, 2009 8:11 PM

All replies

  • hi,

    You should enable PAE (Physical Address Extension) in your OS for the
    applications to use more than 4 GB of "physical memory" when your system
    has > 4 GB RAM. This prevents swapping of page file contents under memory
    pressure.

    Please refer to this KB article for more details.

    http://support.microsoft.com/default.aspx/kb/283037

    Thanks!
    Nikhil
    • Marked as answer by SupachaiS Monday, September 7, 2009 2:29 AM
    Wednesday, September 2, 2009 8:11 PM
  • Thankyou sir.
        but that referlink i do coverup. so that i mean memory for process application.
    Example ---
          Maybe you see in task manager and look at for sas process.exe , see that right menu look for Mem Usage.
                                                                                                                                            Thank you.
                                                                                                                                                Tone.

    Monday, September 7, 2009 2:29 AM