locked
ADF Shared Self Hosted Runtime works on shared ADF services but not on host ADF (Failed to get Status) RRS feed

  • Question

  • Hi

    I have an ADF self hosted runtime installed on 1 VM. This is then shared amongst two other ADF services.

    The runtime works perfectly fine for the 2 ADF services that it is shared too. It does not work on the ADF service from which it was originally setup too (I refer to this as the host ADF).

    There are no errors in event viewer, and the other 2 ADF's work fine. I am not sure how this has broken. Following on from this, the host ADF prior to sharing was working fine. I can confirm their has been no change to the network or OS security of that machine since the share took place.

    The error the host ADF is receiving is "Failed to get Status".

    How can I resolve this? Any ideas would be greatly appreciated.

    Below is a picture of the host ADF with the erroring runtime.

    Below is a picture of one of the shared ADF's with the runtime working as expected

    Thursday, January 16, 2020 2:16 AM

Answers

  • Hi CloudMatt

    Thanks for your query. Just wanted to clarify one thing here that you have mentioned the host SHIR (from original Data factory - in another terms "Shared SHIR") is not working but looking at the images shared, looks like the issue is with the linked IR in another Data Factory and not the original shared SHIR (from original Data factory - i.e ., host Data factory).



    I tried the same and wasn't able to reproduce your error message. All my SHIR's (1 Shared SHIR + 1 Linked SHIR + 1 Linked SHIR) are are running as normal.



    Could you please try deleting the linked SHIR that is having issue and recreate it one more time. If this didn't resolve your issue, please try updating your Integration Runtime to the latest version 4.4.7279.1 released on 1/6/2020 and retry creating the linked SHIR. 

    Here is the download link for latest version IR: https://www.microsoft.com/en-us/download/details.aspx?id=39717


    Please do let us know how it goes.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered"Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.


    Thursday, January 16, 2020 9:16 PM

All replies

  • Hi CloudMatt

    Thanks for your query. Just wanted to clarify one thing here that you have mentioned the host SHIR (from original Data factory - in another terms "Shared SHIR") is not working but looking at the images shared, looks like the issue is with the linked IR in another Data Factory and not the original shared SHIR (from original Data factory - i.e ., host Data factory).



    I tried the same and wasn't able to reproduce your error message. All my SHIR's (1 Shared SHIR + 1 Linked SHIR + 1 Linked SHIR) are are running as normal.



    Could you please try deleting the linked SHIR that is having issue and recreate it one more time. If this didn't resolve your issue, please try updating your Integration Runtime to the latest version 4.4.7279.1 released on 1/6/2020 and retry creating the linked SHIR. 

    Here is the download link for latest version IR: https://www.microsoft.com/en-us/download/details.aspx?id=39717


    Please do let us know how it goes.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered"Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.


    Thursday, January 16, 2020 9:16 PM
  • Thanks for the response KranthiPakala,

    I ended up getting this working, took a little bit of jigging around between GIT and ADF, but I ended up removing the SHIR and re-adding via the arm template of the project. In the end a colleague and I got it working :)

    Have a good day!

    Friday, January 17, 2020 4:12 AM
  • Glad to know your issue was resolved. :) Thanks for confirming. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Friday, January 17, 2020 7:39 PM