X64 not listed in platform, but only in active solution platform? RRS feed

  • Question

  • User1898455574 posted

    So I wanted to create a X64 bit version of my project.

    So I created a new solution platform in the configuration manager.
    X64 based on win32

    So I select X64 for solution but under platform only Win32 is listed, if I try to create a new x64 under platform I get "This platform could not be create because a solution platform of the same name already exists"

     Any help? Am I missunderstanding how this is suppose to work?


    Saturday, August 2, 2008 4:40 AM

All replies

  • User-1363174918 posted

    What project type are you using?

    Monday, August 4, 2008 4:58 PM
  • User2106334115 posted

    I'm having the same issue with a solution with multiple projects.  

    I downloaded log4cxx and loaded the provided .dsw file which msvc90 up-converted to an sln and vcproj file.  I can set the platform for three of the projects to x64 (apr, aprutil and xml) but the log4cxx project balks.  The error message is "This platform could not be created because a solution platform of the same name already exists."

    Monday, February 8, 2010 1:05 PM
  • User2106334115 posted

    The answer is in the New Project Platform dialog box to uncheck the checkbox at the bottom Create New Solution Platforms.

    Monday, February 8, 2010 1:49 PM
  • User-850717535 posted

    Using VS2013, I uncheck "Create new solution platforms", click OK, then nothing happens.

    Friday, March 7, 2014 12:50 PM
  • User670609654 posted

    In case anyone is still dealing with this, I did this to be able to see the x64 option:

    1. Go to each project that isn't showing the option, and right-click > Properties.
    2. Go to the Build tab.
    3. You should see the x64 option in the Platform dropdown, select it.
    4. Now go back to Configuration Manager, and you should see the x64 option there now too.

    EDIT: even after doing the above, selecting the x64 option was not being remembered in Configuration Manager. The short version is that the project file was not being updated correctly for the platform, so no matter how many times I selected it, Visual Studio would determine that it wasn't a valid platform for the project, and revert the setting.

    The long version is: I was dealing with Wix installer projects (.wixproj). Due to a bug in Votive, the Wix plugin for Visual Studio, the .wixproj file was not being updated for the selected platform, or if it was updated, it would place the configuration in the wrong place, so it wouldn't be valid (this SO answer led me to this).

    The workaround is:

    a) Make some other change in the project's Build tab, besides selecting the x64 platform, e.g., add a dummy preprocessor variable. This makes Votive add the correct XML to the .wixproj file.

    b) Manually edit the .wixproj to move the added XML to the correct place in the file (next to the existing platform configurations).

    Wednesday, May 8, 2019 1:10 AM