none
Microsoft .NET Framework installation/removal problems. RRS feed

  • Question

  • I have a problem with installing Microsoft .NET Framework 2.0.

    I am running Vista SP2, so .NET Framework is integrated into the OS. After trying to run an application, I got the 0xc0000135 error.

    I read on some fora that this could be solved by reinstalling your .NET Framework, which was 2.0 in my case.

    After I did so, I still got this error. I tried to seek help at Microsoft Support, who sent me an e-mail back with these options:

    'Download and run: http://tinyurl.com/dotnetclean

    Download and run as administrator: http://tinyurl.com/wuclean

    Download and run as administrator: http://tinyurl.com/wufixvista15

    Then restart your computer and try Windows Update again.'

     

    I did this, but Windows Update gives Code 643: An unknown error has occured in Windows Update*.

    As I also read on the official microsoft site that 3.5 is an upgrade from 3.0, which is an upgrade from 2.0, I thought I would just need to install 2.0 again, after that 3.0 and after that 3.5.

    When I tried to install 2.0, it said that 'this version is already integrated into the operating system and doesn't need to be installed*'. So I tried to install version 3.0, as the installation of 2.0 didn't seem needed. This installation process gave me the message: 'a higher version of this program is already installed, therefore there is no installation needed*'.

    I also got an error message 0x004484b6, but this was only once (not with the same program with which I got the other error message) and I am not sure whether this is because of .NET Framework or not.

    The .NET Framework can not be seen in Control Panel--> all programs in any of the cases.

     

    *Note: I briefly translated this from Dutch. Although it is not exactly the error message, the translation coincides with the error as best as I can.

    Friday, November 5, 2010 5:29 PM

Answers

  • Hi Mr. Davis,

     

    Thank you for posting.

     

    At first, which software would you like to install on your machine?

     

    Vista SP2 is including .NET Framework 2.0 SP2 and 3.0 SP2 by default. I would recommend that you could download .NET Framework Verification Tool to verify whether .NET Framework is installed correctly on your side or not.

    Please check the following link: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

     

    If it failed, I would recommend that you might format your OS. Since your OS might be corrupted.

     

    Regards,

    Larcolais


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Larcolais Gong Friday, November 12, 2010 5:07 AM
    Monday, November 8, 2010 7:19 AM