none
Visual Studio 2017 doesn't allow me to read a Windows font file using the Binary Editor. Why?

    Question

  • I know I can use the function GetFontData() to obtain a copy of any data in the font, in memory. But I would like to have a "quick" look into the font binary to see if I'm following the font layout correctly, as described in the literature. Apparently this is not possible, as when I try to reach the folder C:\Windows\Fonts, I get an error message, like "The operation could not be completed. Parâmetro incorreto". Yes, that sounds weird, as the first part of the message is in English and the last part in Portuguese, which can be translated as "Incorrect parameter". See also the attached image.

    Please find below what I'm trying to do in VS2017: In the File menu I selected Open > File ... and in the dialog box that follows, I try to open the folder C:\Windows\Fonts, where I receive the error message mentioned above. Thanks for any help.

    Sunday, April 16, 2017 7:04 PM

Answers

  • Hi Belloc,

    Welcome to the MSDN forum.

    I tried to Open-File to select the location through click This PC>C:>Windows>Fonts, got the same error message as yours.

    Refer to the error message, please have a try with the following to troubleshot this issue:

    1. Restart the VS 2017 and run as administrator

    2. Remove or delete the cache folder:  %LocalAppData%\Microsoft\VisualStudio\14.0\ComponentModelCache and restart the VS 2017

    3. Open developer command prompt for VS 2017, type devenv /resetuserdata to clear the old user data

    Tested in VS 2015 and got the same result and I compared the properties of this font folder with others, and it looks like different, please have a look at the following:

    I have reported this issue to the VS Product Team, please check this: https://developercommunity.visualstudio.com/content/problem/45142/file-open-file-click-the-this-pccwindowsfonts-and.html and you can vote it or add a comment, then we need to waiting for the response from the VS Product Team Engineers, thank you for your understanding.

    BTW, I found if I directly type the folder location C:\Windows\Fonts in the location field like the following, it can redirect fine, but it looks like there is no available files to open.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Belloc Monday, April 17, 2017 1:11 PM
    Monday, April 17, 2017 9:25 AM
    Moderator