locked
APPX1204: SignTool Error

    Question

  • Hello,
    I ran into a problem with Windows Store apps and search for help.

    If I attempt to create a Visual Studio package (menu Project / Store / Create App Packages ...) then, at the end of the build, I always get such message:

    1>  ClassroomXaml -> D:\projekty\Classroom\

    ClassroomXaml\ClassroomXaml\bin\x86\Master\ClassromXaml.exe 1>  ClassroomXaml -> D:\projekty\Classroom\ClassroomXaml\ClassroomXaml\AppPackages_pzver2\ClassroomXaml_1.0.0.15_x86_Master_Test\ClassroomXaml_1.0.0.15_x86_Master.appx 1>C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\AppxPackage\Microsoft.AppXPackage.Targets(1778,9): error APPX1204: Failed to sign 'D:\projekty\Classroom\ClassroomXaml\ClassroomXaml\AppPackages_pzver2\ClassroomXaml_1.0.0.15_x86_Master_Test\ClassroomXaml_1.0.0.15_x86_Master.appx'. SignTool Error: Access is denied. 1>C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\AppxPackage\Microsoft.AppXPackage.Targets(1778,9): error APPX1204: SignTool Error: An error occurred while attempting to sign: D:\projekty\Classroom\ClassroomXaml\ClassroomXaml\AppPackages_pzver2\ClassroomXaml_1.0.0.15_x86_Master_Test\ClassroomXaml_1.0.0.15_x86_Master.appx 1> 1>C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\AppxPackage\Microsoft.AppXPackage.Targets(1778,9): error APPX1204: ========== Build: 0 succeeded, 1 failed, 2 up-to-date, 0 skipped ==========



    It doesn't matter if I want to pack for Store or not, the result is the same.

    I have no idea what / where "access denied"? File? Certificate?

    I can not say exactly, when it worked last time (about a week), but it also behave same when I do a clean checkout of older version of the project, or if I try to build a branch, in the state in which was sent to the store. So I dare say that it isn't because changes in the project.
    On another computer, build from the same sources works. So I assume that the this isn't because expiration of the license / certificate.

    I have tried:
    - VS and restart your computer
    - Run VS as administrator
    - Do clean checkout of sources
    - Create a new test certificate and then again associate with the store.
    - Also do "Acquire Developer License" again.
    - Add Test certificate as Trusted Root cert. auth. on Local Computer
    - Update to Visual Studio Update 3
    - Do "repair" from installer.
    - Build from the command line (with MSBuild) - the same result.

    How to check where can be the problem?
    On Web or Msdn I didn't found a relevant answer.
    Or should I just go straight into the re-install of Visual Studio and tools?


    I used Windows Pro 8.1 and Visual Studio 2013 Update 3 (2). Package was a Windows Store (Metro) app that has target Windows 8.  On my computer I using only one account and do not realize that I performed any configuration changes or install anything.

    Thanks for any help
    Tuesday, August 26, 2014 11:17 AM

All replies