locked
Can't set Listen All to "NO" in sql 2008 r2 cluster RRS feed

  • Question

  • I have a clustered SQL 2008 R2 instance that I want to listen on a specific IP (the cluster VIP) address and a specific port (1433). I need to do this so that my monitoring software can connect to it on a known IP/port. I thought it would be a simple matter of using SSCM (Sql Server Configuration Mananger) to set "listen all" to  "no", disable all of the IP's except the one for the VIP, and set the port # to 1433. The "listen all" entry however will not stay at "no". I shut down the instance, made the described changes, and exited SSCM. If I restart SSCM, Listen All is back to "yes". How to do set it to NO?

    I also tried it for a non-clustered named instance and the same thing happens.


    Chuck
    Wednesday, November 2, 2011 12:40 PM

Answers

  • Thanks. I encountered that artcle after posting my original message. I also found a work-around to allow me to run a clustered SQL instance on a specific port # and IP address.

    In SSCM...

    On the Protocol tab set "Listen All" to YES (as required in a cluster)

    On the IP Addresses tab:

    - disable all IP addresses except the one representing the instance's VIP
    - At the bottom in the "IP All" section set the port # to 1433 (or whatever port you want to use) and set the "TCP Dynamic ports" property to blank.

    I've tested this configuration with multiple named instances running on the same node use port 1433, but each instance using a different VIP.


    Chuck
    • Marked as answer by chuckh1958 Wednesday, November 2, 2011 2:53 PM
    Wednesday, November 2, 2011 2:53 PM

All replies

  • From the Microsoft SQL Server Support Blog I found this post.

    http://blogs.msdn.com/b/sqlblog/archive/2009/07/17/how-to-configure-sql-server-to-listen-on-different-ports-on-different-ip-addresses.aspx

    It says:  "On cluster, you cannot configure SQL Server to listen on a specific IP addresses. You must chose IPALL. The IP addresses on which the cluster instance will be listening on is determined by cluster resources (configurable through Cluster Administrator, by adding IP Address resources under SQL Network Name resource)."

    RLF

    Wednesday, November 2, 2011 2:47 PM
  • Thanks. I encountered that artcle after posting my original message. I also found a work-around to allow me to run a clustered SQL instance on a specific port # and IP address.

    In SSCM...

    On the Protocol tab set "Listen All" to YES (as required in a cluster)

    On the IP Addresses tab:

    - disable all IP addresses except the one representing the instance's VIP
    - At the bottom in the "IP All" section set the port # to 1433 (or whatever port you want to use) and set the "TCP Dynamic ports" property to blank.

    I've tested this configuration with multiple named instances running on the same node use port 1433, but each instance using a different VIP.


    Chuck
    • Marked as answer by chuckh1958 Wednesday, November 2, 2011 2:53 PM
    Wednesday, November 2, 2011 2:53 PM