none
.NET fails to install on Windows 7 SP1 RRS feed

  • Question

  • I've been having a devil of a time getting .NET updated/installed.

    When I try to install the non-web based install, it gives me a "fatal error during installation".
    The same error comes up when Windows Update tries to install/update .NET

    I've tried researching solutions for others with similar problems and have tried:
    - TechNet .NET fix tool
    - .NET uninstall/re-install
    - Safe mode, apparently .NET won't install in safe mode
    - Go to the temporary folder that the installer creates and ran the netfx_core and extended .msi s directly

    No matter what I try, I end up with the 0x80070643 error, and no working .NET

    Friday, February 26, 2016 10:36 PM

Answers

All replies

  • Please describe the version of .NET Framework. and provide a screenshot of Program and features (Control Panel) related to .NET Framework, and file name you used for installation.
    Saturday, February 27, 2016 8:15 AM
  • Hi Pat Ouellette,

    Thank you for posting in MSDN forum.

    0x80070643 error usually indicates that the install packages are missing or corrupted.

    Since you didn't mention which .NET Framework version you would like to install, I suggest you use .NET

    Framework Setup Verification Tool to check if the .NET Framework is ok. 

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    If you find there is anything wrong with .NET Framework, you may use Microsoft .NET Framework Repair Tool to do a repair:

    https://www.microsoft.com/en-us/download/details.aspx?id=30135 
     
    In addition, you could try using a standalone installer to install .NET Framework.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, February 29, 2016 5:11 AM
    Moderator