locked
Retirement date for Asp.Net 4.5 RRS feed

  • Question

  • User-1699332295 posted

    Looking at: https://www.asp.net/support

    Unless I'm reading that incorrectly it seems that non-core Asp.Net won't be supported from July next year. Is this right?

    Moving to Core can be a fair bit of work

    Also, we have a problem moving to Core because we are heavy users of InProc Session and Core only seems to support Session through serializing the data on every call

    Help please

    Wednesday, July 18, 2018 9:56 AM

Answers

  • User753101303 posted

    Forget about ASP.NET 5 (was an old name for ASP.NET Core and you shouldn't use this any more).

    Then  you have .NET 4.x, ASP.NET 4.x is the part of .NET 4.x that support creating web applications (includes Web Forms for example) and ASP.NET MVC, WebPages, SignalR, EF etc... are out of band components to support creating web apps with particular approaches (see that as "addons" for ASP.NET). I talked about that as from the post title it seemed you are confusing ASP.NET and ASP.NET MVC.

    So in short ASP.NET and those components are still fully supported. The link you provided just tell that for some components you must use the current version and when a new version is out, you have 12 month for doing the upgrade.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 18, 2018 12:31 PM

All replies

  • User753101303 posted

    Hi,

    No and you even have a 4.8 preview. Basically starting with 4.5.2, .NET is supported as long as the corrresponding OS that brought this version is supported.

    The page you saw is for out of band additions such as MVC. My understanding is that the idea is to have no retirement date for the latest version and to support the previous version up to one year after a next version is made available.

    In short, there is no need to hurry up.

    Wednesday, July 18, 2018 11:27 AM
  • User-1699332295 posted

    You're talking about .Net, as opposed to Asp.Net MVC

    I think I was getting confused by the numbers

    Asp.Net 5 = Core = Current release
    Asp.Net MVC 5 = normal (not core) Asp.Net, and this doesn't have an end date

    Is this correct? Not confusing at all

    Wednesday, July 18, 2018 12:00 PM
  • User753101303 posted

    Forget about ASP.NET 5 (was an old name for ASP.NET Core and you shouldn't use this any more).

    Then  you have .NET 4.x, ASP.NET 4.x is the part of .NET 4.x that support creating web applications (includes Web Forms for example) and ASP.NET MVC, WebPages, SignalR, EF etc... are out of band components to support creating web apps with particular approaches (see that as "addons" for ASP.NET). I talked about that as from the post title it seemed you are confusing ASP.NET and ASP.NET MVC.

    So in short ASP.NET and those components are still fully supported. The link you provided just tell that for some components you must use the current version and when a new version is out, you have 12 month for doing the upgrade.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 18, 2018 12:31 PM
  • User-1699332295 posted

    Ok, thanks for that. 

    Wednesday, July 18, 2018 1:27 PM