locked
Slow Code Behind Display RRS feed

  • Question

  • Greetings,

    My stats:

    OS: XP Professional (2002) SP2

    Pentium 4 CPU, 3.2 Ghz, 2.98 G RAM

    App: VS 2008 Pro. v 9.0.21022.8 RTM

    NET framework 3.5, sp1

    My problem:

    When I dbl-click a form or control (vb.net) to access the code-behind page it can take

    more than a minute for the code-behind to appear.

    After some time the cursor changes to a 'gear-wheel and plus sign' image.

    Tried to find a similar problem before bothering the forums.

     

    Any ideas/solutions are most welcome.

    Thanks in advance.

     

    Monday, May 9, 2011 2:37 PM

Answers

  • Hello JoeWilson,

    Thanks for your post.

    Is there any other scenarioes which are also very slow? Only code behind displays slowly? When you create a new project, is it the same scenario? I recommend you could do below steps to check the result first:

    First, please turn off virus checking on devenv.exe.

    Then please try to reset all settings.

    1. On the Tools menu, click Import and Export Settings.

    2. On the Welcome to the Import and Export Settings Wizard page, click Reset all settings and then click Next.

    http://msdn.microsoft.com/en-us/library/ms247075(v=VS.90).aspx (How to: Reset Your Settings)

    By the way, you may be able to improve the overall performance of this product on your computer by doing the steps from MSDN:

    http://msdn.microsoft.com/en-us/library/4c26cc39.aspx

    If you have any concerns, please feel free to follow up.

    Best regards


    Liliane Teng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Liliane Teng Monday, May 16, 2011 3:59 AM
    Wednesday, May 11, 2011 2:39 PM

All replies

  • Hello JoeWilson,

    Thanks for your post.

    Is there any other scenarioes which are also very slow? Only code behind displays slowly? When you create a new project, is it the same scenario? I recommend you could do below steps to check the result first:

    First, please turn off virus checking on devenv.exe.

    Then please try to reset all settings.

    1. On the Tools menu, click Import and Export Settings.

    2. On the Welcome to the Import and Export Settings Wizard page, click Reset all settings and then click Next.

    http://msdn.microsoft.com/en-us/library/ms247075(v=VS.90).aspx (How to: Reset Your Settings)

    By the way, you may be able to improve the overall performance of this product on your computer by doing the steps from MSDN:

    http://msdn.microsoft.com/en-us/library/4c26cc39.aspx

    If you have any concerns, please feel free to follow up.

    Best regards


    Liliane Teng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Liliane Teng Monday, May 16, 2011 3:59 AM
    Wednesday, May 11, 2011 2:39 PM
  • Hello JoeWilson,

    When you come back, if you think it provides no help, please unmark and follow up.

    Best regards


    Liliane Teng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, May 16, 2011 4:00 AM
  • If You have installed additional controls, like Divelements Sandribbons, the designer sometimes stops or really slows down, or even shows stupid Designer Error messages. Look for Visual Studio addins or other controls and remove them.
    • Proposed as answer by Jacob Brown Sunday, May 22, 2011 2:24 PM
    Sunday, May 22, 2011 2:24 PM