none
Support for SHA-2 on Vista/W2K8 RRS feed

  • Question

  • Hello,

    we have purchased fresh code signing SHA-2 certificate and met problem. We declare that our kernel-mode driver based product is compatible from XP/W2K3 to Win8.1/W2K12R2. Problem are OS-es Vistax64/W2K8x64. These systems with the newest updates installed does not trust SHA-2 certificate and customer cannot install product. Win7/W2K8R2 are ok with installed patch by: https://technet.microsoft.com/en-us/library/security/3033929.aspx . Technical support of certification authority told that only solution is to reissue SHA-1 certificate but time will be lost and such certificate will be valid only to Dec/2015. So we paid for one year, but solution expires after half-year because Microsoft will deprecate SHA-1 from Jan-2015. After communication with other CA, it seems that they have the same problem.

    My question:
    If Microsoft want to deprecate SHA-1 from Jan-2016, when Microsoft release SHA-2 patch for Vistax64/W2K8x64 ?

    Wednesday, May 27, 2015 7:37 PM

Answers