locked
mirroring RRS feed

  • Question

  •  

     

    hello

    i used following query to create endpoint

     

    CREATE ENDPOINT Endpoint_Mirroring

    STATE = STARTED

    AS TCP (

    LISTENER_PORT=5024

    , LISTENER_IP = ALL

    )

    FOR DATABASE_MIRRORING (

    AUTHENTICATION = CERTIFICATE HOST_A_cert

    , ENCRYPTION = REQUIRED ALGORITHM RC4

    , ROLE = ALL

    );

    GO

     

    i got the following error msg:

     

    Msg 1498, Level 16, State 2, Line 11

    Database mirroring is disabled by default. Database mirroring is currently provided for evaluation purposes only and is not to be used in production environments. To enable database mirroring for evaluation purposes, use trace flag 1400 during startup. For more information about trace flags and startup options, see SQL Server Books Online.

     

     

    any help plzz

     

    thanks in advance

     

    Sunday, May 6, 2007 9:32 AM

Answers

  • Hello

     

    Support for Database mirroring in SQL Server 2005 as a feature was officially availble in SQL Server 2005 Service Pack 1. Before Service Pack 1 in RTM build you could still use this feature but after Enabling Trace Flag 1400 DBCC TRACEON(1400,-1). I would suggest upgrading to SQL Server 2005 SP1 or SP2.

     

     

    Hope this helps

     

    Vishal Gandhi

     

     

     

     

    Monday, May 7, 2007 4:57 AM

All replies

  • Hello

     

    Support for Database mirroring in SQL Server 2005 as a feature was officially availble in SQL Server 2005 Service Pack 1. Before Service Pack 1 in RTM build you could still use this feature but after Enabling Trace Flag 1400 DBCC TRACEON(1400,-1). I would suggest upgrading to SQL Server 2005 SP1 or SP2.

     

     

    Hope this helps

     

    Vishal Gandhi

     

     

     

     

    Monday, May 7, 2007 4:57 AM
  •  

     

    thanks  vishal

     

    i downloaded  sp2 i check its created the endpoints properly, let me check whether mirroring will work proper or not.

     

     

    Tuesday, May 8, 2007 8:01 AM