none
---EDIT button on the ribbon is not functioning any more---Please help! RRS feed

  • Question

  • Hi guys,

    I was editing a BI webpart to the site's front page.  The link was wrong there and it gave me the error in the red ink. So without pressing OK or Cancel I clicked on the task list. After I returned back to the front page and try to press "edit page" button it gives me the following error in pop out message:

    "Sys.Invalid Operation Exception: Could not find the UpdatePanel with ID: ".....". If it is being updated automatically then it is under another UpdatePanel"

    And then the ribbon doesn't show the Edit mode. It stays in Browse mode.

    Since I didn't do any programming other then trying to hook up a list into this webpart - I just hope there is easy fix to it...

    Any thoughts would be very appreciated.

    Thank you.


    Wednesday, April 6, 2011 4:18 PM

Answers

All replies

  • Just a thought, try restarting IIS on your web frontends.
    Lewis_Carroll "His answer trickled through my head like water through a sieve."
    Wednesday, April 6, 2011 4:47 PM
  • Thank you for the input... But that's not it... It's been restarted several times and it's still there...
    Wednesday, April 6, 2011 4:53 PM
  • Try this and see if you can get to the page, append a ?ToolPaneView=2 to the end of your url for the page you want to edit

    Example: if your page was http://MySharePoint/Pages/default.aspx append the ?ToolPaneView=2 to the end so it would be http://MySharePoint/Pages/default.aspx?ToolPaneView=2.  This is another way to get to the edit page.


    Lewis_Carroll "His answer trickled through my head like water through a sieve."
    • Marked as answer by eclipsen2002 Wednesday, April 6, 2011 8:09 PM
    Wednesday, April 6, 2011 5:54 PM
  • WOW!  thank you! it worked!

    Well, one of the sites that was corrapted this way I ended up to roll back to one of the previous versions of the page - that worked too.

     

    Thank you again!!!!!!!!!

    Wednesday, April 6, 2011 8:11 PM