none
kinect-demos ShapeGame.exe failure of audio-stuff RRS feed

  • Question

  • ref: kinect-demos ShapeGame.exe failure of audio-stuff basics: quadcore-HP-laptop (windows7 64bit) hi yesterday i have successfully download the kinect-sdk-beta download. first i have download the prerequisites as per your docs. audio: as per ProgrammingGuide_KinectSDK.pdf download For Speech(x86) -Microsoft SpeechPlatform-Server Runtime, version 10.2(x86) edition -Microsoft Speech Platform - Software Development Kit, (version 10.2 (x86 edition) -Kinect for Windows Runtime Language Pack, version 0.9 - gameshape.exe running perfectly (skeleton and blobs) - but on the downSide of the window: - one or more of the speech prerequisites has not been installed. please consult the readme for more information. now my questions: whats going wrong with the audio ?? have i made a mistake or its possible that OS win7 (64bit) and the audio-stuff is 32bit ??? thanks for hints and help PS. the 2 demos are great.... excuse my bad english regards nomadics
    Saturday, June 18, 2011 8:48 AM

Answers

All replies

  • Hi nomadics

    I had the same problem, but have solved it by downloading the speech language pack from Microsoft.

    The shapegame readme file says in the PREREQUISITES section: "Kinect English Language Pack: MSKinectLangPack_enUS.msi (available in the same location as the Kinect for Windows SDK Beta)."

    It was not part of my SDK installation, but a separate download solved it.

    Give it a go - it works perfect on my machine.

    best regards

    Peter

    <cite>go.microsoft.com/fwlink/?LinkId=220942</cite>


    "Sometimes, a majority simply means that all the fools are on the same side."
    Monday, June 20, 2011 8:51 PM
  • It worked for me too. As Peter suggested, the read me file says:

    =============================
    PREREQUISITES  
    .............................
    - Speech Platform Runtime (v10.2) x86. Even on x64 platforms, the x86 must be used because the Microsoft Research Kinect SDK Beta runtime is x86.
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=bb0f72cb-b86b-46d1-bf06-665895a313c7
    - Speech Platform SDK (v10.2)
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=1b1604d3-4f66-4241-9a21-90a294a5c9a4&displaylang=en
    - Kinect English Language Pack: MSKinectLangPack_enUS.msi (available in the same location as the Kinect for Windows SDK Beta).

     

    Monday, June 20, 2011 11:37 PM
  • Nomadics, is the problem solved by the suggestions below, or do you still have an issue? If you still have an issue, please try to compile ShapeGame sample from VisualStudio yourself (it should be found under C:\Users\Public\Documents\Microsoft Research KinectSDK Samples\NUI\ShapeGame). Then, put a breakpoint in the constructor of Recognizer class and step through. That should give you more information. If you see any suspicious debug output or exceptions are thrown, please let me know what the exception call stack is and paste the debug output here and I'll try to help you more.

    Hope this helps!
    Eddy


    I'm here to help
    Thursday, June 23, 2011 1:52 AM