none
Azure alert rule deleted but still active. RRS feed

  • Question

  • An Azure alert rule was deleted via the Azure portal but's it's still active and sending out (a lot....) notifications.

    The rule can't be found anymore within the Azure portal and it's even not listed by the Get-AlertRule powershell cmd.

    Anyone else seen this problem and know's how to fix...?

    Monday, October 5, 2015 9:42 AM

All replies

  • Hello Martjes,

    1. Did you use the classic portal to delete the rule?
    2. Have you ensured that any of the alert rules are not enabled for your website?

    It could be possible that you are getting emails alerts for rules that are for previous monitoring.

    Thanks,
    Syed Irfan Hussain

    Monday, October 5, 2015 12:17 PM
    Moderator
  • Hi Syed,

    Most probably deleted the rule in the new portal but I'am not totally sure in this.

    The rule name and the web-app name in the alert mail is very specific so no confusion there, the rule just can't be found with the powershell cmd or within the old/new portal.

    -- Martjes

    Monday, October 5, 2015 1:09 PM
  • Hello,

    I am currently checking on this, please give me the your website details indirectly following the instructions in the link below:

    https://github.com/projectkudu/kudu/wiki/Reporting-your-site-name-without-posting-it-publicly

    Thanks,
    Syed Irfan Hussain

    Tuesday, October 6, 2015 10:56 AM
    Moderator
  • Hi Syed,

    It's about website "prod-vlisco-com" with rule "prodvliscocom memory-10126a4f-ad7f-46ee-af62-7e397761e315"

    Tnx for looking into this.

    -- Martjes

    Thursday, October 8, 2015 11:57 AM
  • Hello Martjes,

    Thank you for the information, I am currently looking into this and will get back to you shortly. Thank you for your patience.

    Thanks,
    Syed Irfan Hussain

    Sunday, October 11, 2015 9:49 AM
    Moderator
  • Hello Martjes,

    I have looked at the backend logs and currently find no rules active for this website. However, we are still investigating. Can you please give me the exact time stamps when you get these alerts?

    Thanks,
    Syed Irfan Hussain

    Tuesday, October 13, 2015 2:15 PM
    Moderator
  • Hi Syed,

    Below the mail headers for a mail alert we just received.

    -- Martjes 

    Received: from blugmehub09.msn.com ([65.55.234.208] helo=smtpi.msn.com)
     by mx1.core.nines.nl with esmtps (TLSv1:AES256-SHA:256)
     (Exim 4.85)
     (envelope-from <alerts-noreply@mail.windowsazure.com>)
     id 1ZpddA-0007ja-PJ
     for XXXXX@XXXX.XX; Fri, 23 Oct 2015 16:47:48 +0200
    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
     d=mail.windowsazure.com; s=s1024; t=1445611662; h=From:Subject:Date
     :Message-ID:To:MIME-Version:Content-Type; bh=y1VRjwp/M9hCDt0eJvv7NhCAA8wv
     3ZFw2q6s1h8vpfU=; b=diziHThdn4PrXxHtALvys/vQCiYggpP9z2M5dU8gANi1zje2LCHBh
     RvN3Nugeha9lOLj9+iIoyzXA/H4PDBZuA8ucKUpp4wb1iHvuL2n3ANCI7AeZISf2gR/1PFH1D
     p6SZmezHJHp+OHnjaVkLuw+1/2JVmH6JUIvLMTdhNv1Qo=;
    MIME-Version: 1.0
    From: Microsoft Azure Alerts <alerts-noreply@mail.windowsazure.com>
    To: <XXXXX@XXXX.XX>
    Date: Fri, 23 Oct 2015 14:47:42 +0000
    Subject: [ALERT ACTIVATED] - Average memory working set GreaterThan
     2684354560 (Bytes) in the last 5 minutes

    Friday, October 23, 2015 3:07 PM
  • Hi -

    We have the same problem with our website. The alert was deleted but it still seems to active and we are getting a lot of notifications. It doesn't appear anywhere on the old/new portal. 

    Did you or anyone else know how to fix this?

    Thanks, 

    -Abhinav

    Sunday, November 1, 2015 1:37 AM
  • Hello Martjes,

    We would request you to create a support ticket and we would like to check on the rules. You can follow the link to create a support ticket:

    https://azure.microsoft.com/en-in/support/options/

    Thanks,
    Syed Irfan Hussain

    Tuesday, November 3, 2015 2:59 PM
    Moderator
  • Hi Syed,

    Creating a ticket doesn't seem possible without a support plan, do we need to get a paid support plan to continue solving this issue...?

    -- Martjes

    Sunday, November 8, 2015 10:24 PM