none
Connecting MS Access data base on 64 bit vista machine RRS feed

  • Question

  • Hi Everyone,

    In my application i am using OLEDB 4.0 to connect the MS access database. It works fine on 32 bit vista machine. but gives an error while run on the 64 bit machine, error  "The Microsoft.jet.oledb 4.0 not registered on the local machine".

    I did google for this, Got some thing like this "their is no 64 bit version of jet engine available so it is not working". I build my application as X86 and run, but still giving the same error.

    Please help me to solve this problem.

    Thanks in advance.


    gireesh
    • Changed type YiChun Chen Monday, May 4, 2009 2:58 AM Do not follow up
    • Changed type YiChun Chen Tuesday, May 5, 2009 2:02 AM Follow up
    Monday, April 27, 2009 11:53 AM

Answers

  • Thank you for ur replay.

    Problem got solved, I am developing the windows application, As the Microsoft.Jet.Oledb 4.0 not supported on the 64 bit vista, I build my application for X86 then it works fine on the vista 64 bit version.

    Gireesh
    gireesh
    • Marked as answer by YiChun Chen Tuesday, May 5, 2009 2:02 AM
    Monday, May 4, 2009 7:34 PM

All replies

  • Hi Giri12,

    More clarification with you. What kind of project are you developing now? Winform application? How did you deploy your application? Setup project? Did you receive this error message when you ran the setup file or built your application?

    Thanks


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, April 29, 2009 3:15 AM
  • Hi Giri12,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, May 4, 2009 2:58 AM
  • Thank you for ur replay.

    Problem got solved, I am developing the windows application, As the Microsoft.Jet.Oledb 4.0 not supported on the 64 bit vista, I build my application for X86 then it works fine on the vista 64 bit version.

    Gireesh
    gireesh
    • Marked as answer by YiChun Chen Tuesday, May 5, 2009 2:02 AM
    Monday, May 4, 2009 7:34 PM